Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".


Virtual Office HTML5 RDP not going to full screen

TSOL68TSOL68 Newbie ✭

I have a TZ-570 and I have configured Virtual Office HTML5 RDP bookmarks to our Windows 2016 RDS server. The RDS sessions open but there are scroll bars on most computers. I am can get the session to open in full screen mode by clicking the shield and selecting full screen. However, when I do that, the window does go full screen but the RDP session is only a small portion of the screen. The rest of the screen is the "SonicWall all rights reserved" black background. Also, I cannot click on any of the icons. Has anyone else had this issue and discovered a resolution?

Category: SSL VPN

Best Answer

  • Options
    ThKThK Cybersecurity Overlord ✭✭✭
    edited February 2022 Answer ✓

    on your bookmark setttings please find "RDP Options" for me best practise is "ScreenSize": Fit in Window

    also Test setting in "Show advanced Windows options" in section "Advanced Windows Options". Here you find also settings regarding the Native client. Means just open a netextender connection and use mstsc.exe

    Is here the Screen resolution same as with rdp over html ?



  • Options
    MitatOngeMitatOnge All-Knowing Sage ✭✭✭✭

    Hi @TSOL68 ,

    did you try different browser? check the bookmark screen resulation settings.

  • Options
    TSOL68TSOL68 Newbie ✭

    Yes, IE, Edge, Chrome, and Firefox. Tried all resolution settings in the bookmark and I even read the tech note about not being able to "automatically" going into full screen and it has to be manually done via the shield.

  • Options
    RikardBRikardB Newbie ✭


    We have the same issue here with a SMA 500.

    We allow both Native and HTML5, when setting the full screen option the Native client accepts it and goes to full screen or managable screen resolution.

    When using the H5 mode it will never automatically start to full screen, it starts on the correct resolution adding the scrollbars to the window but to gain full access you have to switch with the shield.

    To mitigate this i changed the settings for the bookmark to " fit in window " making the H5 client to fit correctly in the current window.

    However when using the native client now it just starts in a 800x600 window and you cant change that resolution.

    I tried adding the /f parameter for the native client but it will still not launch in full screen.

  • Options
    RikardBRikardB Newbie ✭

    Is Sonicwall representatives using the forum or is this just community based!?

    We dont have any support contract atm (signing it asap) for our SMA 500, but as this seems to be something that not just affects us it should be acknowledged by Sonicwall imo.

  • Options
    BWCBWC Cybersecurity Overlord ✭✭✭
    edited January 2023


    That's what ChatGPT has to say (I had to test it):

    The SonicWALL community is a user forum and support platform for users of SonicWALL products and services. It is a place where users can ask questions, share knowledge, and get help with using and troubleshooting SonicWALL products. It is also a place where users can learn about new features and updates to SonicWALL products, and provide feedback to the company. The community is moderated by SonicWALL staff and volunteers, and is intended to be a helpful and supportive resource for users of SonicWALL products.

    Don't expect much interaction from SonicWall, it sometimes happens but I wouldn't count on it. Have your products under contact and hope for the best that Support can be helpful. Partnering up with a SonicWall Partner also helps, but they are left sometimes in the dark as well.

    Did you tried different browser? Because in the past I had different outcomes with Firefox and Chrome running HTML5 RDP.


Sign In or Register to comment.