Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

Configure SonicWall WAN / X1 Interface With Static IP Address *and a VLAN ID*

Hi,

I am trying to set up a static IP for our TZ370W. I did see this post:

https://www.sonicwall.com/support/knowledge-base/how-can-i-configure-the-sonicwall-wan-x1-interface-with-static-ip-address/170503917481882/

But I can't get it to work. There is just no internet connection after I do the setup (all pings fails, etc...)

Our co-working space provided us with the static IP, subnet mask, gateway, and DNS information... but also a specific VLAN ID. I suspect this is the problem.

How/where can I specify the VLAN ID for this to work?

Thanks so much

B

Category: Entry Level Firewalls
Reply

Answers

  • TKWITSTKWITS Cybersecurity Overlord ✭✭✭

    Remove the current configuration of X1 and add a subinterface to X1 tagging the appropriate VLAN ID.

    Or you can have your 'co-working space' provide you an 'access' or 'untagged' port instead of requiring tagging from you.

  • BenoitBenoit Newbie ✭

    Hi,

    Thanks so much for your answer.

    I tried to add a virtual interface X1:V50 (VLAND ID=50 is what the co-working space communicated)

    But sorry I'm not sure to understand what "Remove the current configuration of X1" mean.

    If I choose Zone="Unassigned" for X1 it complains "One WAN interface must be selected for Failover & LB groups".

    I tried to keep X1 with Zone=WAN and DHCP, and then setup all the IP/mask/gateway/dns/VLAN ID in X1:50 but ping still fails

    I also tried to setup IP/mask/gateway/dns/VLAN ID on X2:50 and change the cable to X2 , but ping fails as well.

    Thanks again

    B

  • TKWITSTKWITS Cybersecurity Overlord ✭✭✭

    I said 'remove the current configuraiton of X1' because I didn't want you to use the same IP address/mask/etc. on X1 and your subinterface.

    Were you doing the ping from the X1:V10 interface? Did you set X1:V50 as the preferred Failover/LB interface? This is an older article but it would help.

    Or you can have your 'co-working space' provide you an 'access' or 'untagged' port instead of requiring tagging from you.

  • BenoitBenoit Newbie ✭

    Thanks. I tried various things that I think should have worked, but it did not.

    At the end they changed the config, gave me an untagged port, and it just worked in 2sec.

    THanks though!

Sign In or Register to comment.