Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

NSA2400MX Link Speed 100Mbps

Halon5Halon5 Enthusiast ✭✭

Hey Folks,

Can anyone remember why the NSA2400MX gets link speeds stuck at only 100Mbps when they should clearly go to 1Gbps?

Doesn't work when manually set on the network interface 1Gbps...

So downstream switch connect wont go faster than 100Mbps .. Arghhhh..

I could swear I have seen this issue eons ago... diags.html?

Thanks for any help.

Category: Mid Range Firewalls


  • prestonpreston Enthusiast ✭✭

    Hi @Halon5 , I haven't got an NSA2400MX to test with, don't think there is anything in the Diag which would help, the first thing I would try is to disable anything to do with IPv6 on the Interface, you might need to reboot or unplug and plug back in the cable, obviously check with other cat5e/6 cables also.

  • AjishlalAjishlal Community Legend ✭✭✭✭✭
    edited May 2021

    Hi @Halon5

    1st change the cable if it's not help adjust the interface duplex mode (Auto negotiate) to manual and select 1Gbps and try.

    3rd check your Switch interface port will support 1Gbps ( Check interface port configured with full duplex or not) for testing connect the same switch port with PC/Laptop Giga interface.

  • Halon5Halon5 Enthusiast ✭✭

    Hey @Ajishlal ,@preston ,

    Thanks for your input.

    Tried all the obvious stuff. Still no go. Just sticks to 100mpbs/Full. So annoying. I could swear I have had this problem with NSA2400MX before. Some time long ago no doubt.


    Thanks, Steph.

Sign In or Register to comment.