Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

Remote desktop lag over VPN (NetExtender)

Hello,

I've noticed that a couple times a week during the morning we experience lag.

We VPN in and then use Remote desktop. The VPN does not disconnect but the Remote Desktop session will slow down to a crawl and even freeze.

The firewall CPU usage is fine and the egress/ingress is fine to.

Doesn't seem that the firewall is being over used.

Any clues on on trying to troubleshoot this issue?


Thanks,

Jayser

Category: Entry Level Firewalls
Reply
Tagged:

Answers

  • AlbertoAlberto Newbie ✭
    Can you give us your firmware version ?
  • JayserJayser Newbie ✭

    we are running  6.5.2.1-31n

    I am planning on upgrading to the current one this weekend.

  • BGMRobBGMRob Newbie ✭

    This sounds similar to an issue that we were experiencing. The NetExtender would stay connected but the RDP session would freeze. Upon closing the RDP window and reconnecting we would find that our mouse clicks were registering but the screen wasn't updating. I Googled and found the solution below. I made the changes on both the PCs we were RDPing into and the laptops we were RDPing from. It fixed the issue for us twice.

    Run gpedit.msc. 

    Navigate to Computer Configuration > Administration Templates > Windows Components > Remote Desktop Services > Remote Desktop Connection Client. 

    Set the "Turn Off UDP On Client" setting to Enabled

  • JayserJayser Newbie ✭

    We tried the UDP solution for a few computers. It helped with some of the freezing for some. But this seems a bit different, like it's a slow down of RDP traffic. Everyone that is in the office doesn't feel it at all. Speed test are fine.

    I forgot to mention that when we do have this issue, even if I use logmein, that is slow too.

  • SaravananSaravanan Moderator

    Hi @JAYSER,

    Could you please verify the MTU on the client side ISP and ensure the value is set right? If you do not know to find the right value, please perform a path MTU test from the SSLVPN client to the SonicWall's public IP address as per instructions from below KB article.

    Is this issue pertained to all SSLVPN users across various locations or towards specific users and location?

    Below is a generic KB article to tweak the performance of SonicWall. Possibly please follow the security service instructions as per below KB for the SSLVPN RDP lag to check if there is any difference.

    Let us know how it goes. Have a good one.

    Regards

    Saravanan V

    Technical Support Advisor - Premier Services

    Professional Services

  • JayserJayser Newbie ✭

    Thank you. I'll look into that.

    The weird thing is it's only happening between 8:30-Noon. After that it's fine. And it's only a handful of users.

Sign In or Register to comment.