Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".


Cannot Install NetExtender on my Windows 10 Surface Book 3

SchuSchu Newbie ✭

We have a number of Surface laptops, all able to connect to our VPN tunnel without a problem. We recently purchased a Surface Book 3, and Netextender will not install properly. We get the following error:

We have tried installing the following versions without success:


We have tried various compatibility modes as well as "run as administrator" during install, as well as with the executable after install. We have reinstalled Windows 10 twice (Sonicwall solution), trying to resolve this issue. We have never encountered this problem before, and would like someone to tell us what the magic bullet is to fix it. It must be a registry key somewhere.

Category: VPN Client

Best Answers


  • Options
    SchuSchu Newbie ✭

    Hi Shipra Sahu,

    You definitely solved this for us. The setting in core isolation for memory integrity was indeed "ON" and greyed out. Before we made any changes, we went to two other Windows 10 systems using Sonicwall NetExtender and checked the settings. The memory integrity on those systems was set to "OFF". This tells us that this is not a group policy setting of some kind, it just happened to be in that state for that computer.

    We changed the registry key as suggested, restarted the computer, and now the Netextender works flawlessly.

    Thanks so much for this solution.


  • Options
    SchuSchu Newbie ✭

    I will now!

  • Options
    MPEChuckMPEChuck Newbie ✭

    I'm curious why the first solution is to disable a security setting...? Especially in this era of increased attacks on organizations through software such as Sonicwall... What kind of risks am I opening myself to if I turn this protection off?

    Wouldn't it make more sense to try the SonicWall Mobile Connect approach first? Or are there downsides to that?

    When I ran into the error that SCHU describes, the first thing I tried was turning off Secure Boot. I'm assuming that this isn't necessary if I toggle off the Memory integrity setting above.

    We are running version 10.2.302. So, still no fix for this issue...

    Thanks for your thoughts.

Sign In or Register to comment.