Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

ES 10.0.6 - Attachments in Junk Box - depending on mailformat

BWCBWC Cybersecurity Overlord ✭✭✭

Hi,

when checking the attachments in mails which got into the Junk box, sometimes the attachments are selectable, sometimes not. It seems this is related how the email is formatted,

If "Content-Transfer-Encoding: base64" (e.g. through SAP Netweaver) then the attachment is not selectable:

On the other hand if the mail comes as "Content-Type: multipart/mixed;" we are mostly lucky.


Is this already addressed and could the message parsing expanded that the Junk Box gets more useful, because customers like to check first in the Junk Box before releasing the mail.

--Michael@BWC

Category: Email Security Appliances
Reply

Answers

  • shiprasahu93shiprasahu93 Moderator

    Adding @RuheeSafiya from ES team for further help.

    Shipra Sahu

    Technical Support Advisor, Premier Services

  • RuheeSafiyaRuheeSafiya SonicWall Employee

    Hello @BWC ,

    This was a reported issue "Attachment having non-english names cannot be viewed in auditing"and a bug was filed : ES-2653 . This issue was resolved in 10.0.3 firmware version. Could you please let me know the firmware version of your Email security ?

    Thank!

    Ruhee Safiya F

    Enterprise Technical Support Sr Analyst

  • BWCBWC Cybersecurity Overlord ✭✭✭

    Hi @RuheeSafiya

    this specific customer is still on 10.0.2, because it's someone I cannot explain constant segfaults (like from 10.0.3 onwards) to. But to be honest, the attachments which are viewable have non-english names as well.

    On my 10.0.6 installation this seems to happen as well:

    This specific message has a "Content-Type: multipart/alternative;" if this is somehow related.

    --Michael@BWC

  • AnkurAnkur Moderator

    @RuheeSafiya : if it helps, lets ask @BWC to create a support case - add all details, collect sample and feed this into Dev and QA team for validation and fix.

  • RuheeSafiyaRuheeSafiya SonicWall Employee

    Hello @BWC ,

    If this is an existing issue with 10.0.6 , I would request you to get in touch with our Sonicwall Support team so we can troubleshoot and collect the data to report it to our Dev and QA team as mentioned by @Ankur .

    As far as the segfaults error on firmwares above 10.0.3 , we have a reported bug ES-4020 but we do have a workaround for this one which would require a root access to the box and this troubleshooting will be performed by the Sonicwall support team.

    Thank you ,

    Ruhee Safiya F

    Enterprise Technical Support Sr Analyst

  • BWCBWC Cybersecurity Overlord ✭✭✭

    Hi @RuheeSafiya

    thanks for the reply, will check if the customer customer is willing to pay me for another support case, which tend to be very time intensive when ESA is involved. Probably will give it a shot when a newer firmware is available.

    I'am somewhat fatigued about the workarounds, it's 4 months since the last firmware release and the segfaults are there since 8 months? Just get it fixed and stop putting the burden on the partners to take the blame. I guess "workaround" is something that really triggers me.

    --Michael@BWC

  • Halon5Halon5 Enthusiast ✭✭

    Hi @RuheeSafiya ,

    I'm with @BWC , I just spent two full days for which I was not paid by anyone to explain that ES cant even manage SPF properly and all I got was an RFE which almost certainly won't get actioned. @BWC , also put in a major effort to confirm, what I was seeing.

    I reported the same problem three years ago via support case.

    We need some developers to get this stuff fixed and we need some customer advocate at SonicWALL support this stuff. These are ordinary things.

    ---Steph.

Sign In or Register to comment.