Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".


Issues Setting up SSL VPN for the first time

Twizz728Twizz728 Newbie ✭

Hello all,

I am trying to get SSL VPN setup so that I can gain access to my work network to perform some tasks on the network. We use TeamViewer, but it’s slow sometimes, and a lot of the resources I need are web interfaces for different pieces of hardware on our network. I have tried setting up the SSL VPN like the notes say and also watched a couple YouTube videos, but I’ve been unsuccessful. I have the client setup on my laptop, I connect, but I’m never given an IP address for the company network, and for some reason when I connect it shows my SonicWall virtual adapter as being disabled? Not for sure why it does that when I connect. The steps I have performed so far are,

Created a local user and assigned that user to the SSLVPN Services group. Made sure the user had access to the X0 subnet.

Through the SSL VPN tab I’ve enabled WAN and left the other settings as default.

In the client settings I’ve updated the Default Device Profile with the Zone IP V4 to SSLVPN, Network address IP V4 (On this one I have defined a specific host address and a range on the local network because I thought this may have been the issue, but I prefer the range of about 10 addresses).

And then I went into VPN base settings and enabled WAN GroupVPN.

When I connect, I do an ipconfig and it only shows my local ethernet information. Nothing for the VPN.

Any ideas?

Category: SSL VPN

Best Answer


  • Options
    MarkDMarkD Cybersecurity Overlord ✭✭✭

    What client do you have installed? enabled WAN GroupVPN - this is for the IPSEC client (global VPN) and not needed for SSL

  • Options
    Twizz728Twizz728 Newbie ✭

    I have the Global VPN Client version 4.9.22 installed. Yeah every video I saw didn't have enabling the VPN base settings WAN GroupVPN. I just thought that was an overlooked step. Before enabling I couldn't of course get Global VPN Client to work. Is there a different client I need to install, and is there an advantage or disadvantage to using the Global VPN client?

  • Options
    Twizz728Twizz728 Newbie ✭

    @MarkD that fixed it. I installed the NetExtender and now I have an IP for my network and can access network resources.

    Thank you MarkD!

Sign In or Register to comment.