Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".


Connect Tunnel Client 12.43 - BUG / password cannot contain "###"

If you create an Active Directory account password with the characters "###" in it, the Connect Tunnel 12.4.3 client will not work properly with it and will prompt you for credentials on every connect or disconnect/reconnect cycle. If you change the password so it does not contain ### it will work. FYI - the password can contain 2 pound characters "##" and work with connect tunnel. I did not try other special characters or counts. This problem has existed for several years of connect tunnel, I just did not report it in the past.
Please do not ask for logs until you have tested this in your lab environment.

I have entered a ticket - but wanted to drop this here as well

Category: VPN Client

Best Answer

  • Options
    vkrtandravkrtandra SonicWall Employee
    Answer ✓

    Hi @Doug_Daniel ,

    The 3 pound characters "###" has special purpose and was designed a long ago (~10+ years) for credential caching. The rational at that time was no one will likely use a password with that combination and has served until now.


  • Options
    Doug_DanielDoug_Daniel Newbie ✭

  • Options
    brunodavidbrunodavid Newbie ✭

    The "connect-tunnel-client-12-43" bug restricts passwords from containing certain characters, Best Internet Packages causing inconvenience for users. This limitation may stem from security protocols or programming oversights within the system. To address this issue, users can try using alphanumeric passwords without special characters, or they may need to update the client software to a version that resolves this bug. Ensuring compatibility and security while maintaining password integrity is essential for a smooth user experience.

Sign In or Register to comment.