Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".


Implimenting IP phone with EPABX between my 2 VPN, phone is ringing but voice not passing both side,

I want to understand where i am making mistake!

as per my knowledge we dont need to do Port forwarding or any other rules creation or poilcy creation as it is in VPN.

Nobody will call from outside the network, it will work as Intercom only.

Category: Firewall Management and Analytics

Best Answers

  • Options
    A_ElliottA_Elliott Enthusiast ✭✭
    Answer ✓

    What are your UDP timeout settings? You might need to increase those.

    Any insight as to what PBX & endpoint you're working with? That may help.

  • Options
    dp8dp8 Newbie ✭
    Answer ✓

    The Exect Solution I found is here, this will help.



    -Edited Access Rule- LAN to VPN- "Advanced" Tab- UDP Connection Inactivity timeout [300], then Check the box "Disable DPI"

    -Edited Access Rule- VPN to LAN- "Advanced" Tab- UDP Connection Inactivity timeout [300], then Check the box "Disable DPI"

    -Open VPN Tunnel- "Advanced" Tab- Check the box "Disable IPsec Anty-Replay"

    -Open "VoIP" from the left panel- "Settings"- Check the box "Enable Consistent NAT", then Disable "SIP Transformation" if it's enabled.

    These settings must be done on both side's Firewalls.


    Pin-Points noticed during diagnosis-

    -The first thing to keep in mind is there is no need for PAT or NAT manually.

    -No need to create any kind of Access rule.

    -No need to create an Address Object (if we want to bypass Rules and Block for EPABX only that is Exceptional).

    -No need to create a Service Object most probably (if the EPABX vendor needs a different port that is Exceptional).

    -It's Recommended that Disabled "SIP Transformation" for a smooth calling experience.

    -Check if ALG (Application Layer Gateway) settings as well, it could cause a "One Way Audio" problem.


  • Options
    BWCBWC Cybersecurity Overlord ✭✭✭

    @dp8 did you checked with the Packet-Monitor if any packets get dropped for the involved devices?

    In my experience the signalling is done by Phone to PBX but the voice data is transferred between the two Phones directly. Does your Access Rules allow this? Is the default gateway set properly on the phones so they can find each other?


  • Options
    ArkwrightArkwright All-Knowing Sage ✭✭✭✭

    Find the IP address of the two devices, start a call and leave it running whilst checking the Connection Monitor. Filter in the monitor on the IP of the phones [I am assuming we are talking about hardware phones here]. Look in the connection monitor for connections that have TX bytes and 0 RX bytes [or vice-versa]. Those will be the connections that aren't working.

  • Options
    dp8dp8 Newbie ✭
    edited December 2023

    @BWC @Arkwright

    First of all Thanks for Reply.

    yes tried packet capture.

    whatever the Packets coming and going from the IP phone are consumed and forwarded to the other end, in packet capture.

    Yes its a Hardware device.

    do we need to create access rule for VPN while everything is allowed in VPN.

  • Options
    ArkwrightArkwright All-Knowing Sage ✭✭✭✭

    If everything is already allowed then another allow rule isn't going to fix anything.

  • Options
    dp8dp8 Newbie ✭

    even in last i have enabled SIP Transformation, but still not going thru.

    can anybody help me with this?

  • Options
    ArkwrightArkwright All-Knowing Sage ✭✭✭✭

    Did you do what I said in my first post?

Sign In or Register to comment.