Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

NetExtender Breaks Connection to Microsoft Services

TTCBTTCB Newbie ✭

We have clients where Sonicwall NetExtender is breaking the connection to Exchange Online from Outlook, Microsoft Teams is broken, etc. This was supposed to be fixed with NetExtender 10.2.336 with issue ID SMA-4585, but it is still occurring with the latest version 10.2.337.

Has anyone been able to get Sonicwall to acknowledge this is still a problem? Are they working on a fix?

I have called Sonicwall phone support and they have not provided a permanent solution or any guidance as to what's going on whatsoever. We have been dealing with this for 6+ months now.

Category: VPN Client
Reply

Answers

  • SeerSeer Newbie ✭

    I have also recently been struck by this. I was confounded by the cause for a while, and then found these posts.

    I just 'fixed' a new user's machine whose brand-new PC has only seen 10.2.337 and they got this bug on their 2nd day on the job.

    The fix I used was this:

    Run this in an Admin Command window:

    RunDll32.exe InetCpl.cpl,ResetIEtoDefaults

    Select 'delete personal' whatever and run it.

    Download this: Microsoft Support and Recovery Assistant Enterprise version - Microsoft 365 | Microsoft Learn

    Run the following commands in the place you unziped it:

    SaRAcmd.exe -S OfficeActivationScenario -AcceptEula -CloseOffice

    SaRAcmd.exe -S ResetOfficeActivation -AcceptEula -CloseOffice

    Then open Word and log in. You may need to reboot before it works.

    The question is, what's the deal with the registry key in HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Connections

  • MarkVHMarkVH Newbie ✭
    edited November 2023

    I found on another site adding the following to the NxDisconnect.bat file for the connection. Add the line after the Echo Off and before the first REM line:

    reg add "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections" /f /v "DefaultConnectionSettings" /t REG_BINARY /d "4600000002000000090000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000"

    So far, in my tests, I have not seen the issue of connecting to M365 apps.

Sign In or Register to comment.