Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

Unable to Connect to SQL Server

Hello, I'm unable to a client's on-premise SQL Server database through NetExtender. I've seen the problem with Windows 10 and Windows 11 on the same machine, but not when running a Windows 11 VM with KVM on NixOS (same machine). I have no problem pinging a server, but if I try to ping the database port, it fails:

PowerShell: Test-NetConnection -ComputerName server.domain.local will result in a successful ping

PowerShell: Test-NetConnection -ComputerName server.domain.local -port 1433 fails.

My suspicion is that Tailscale VPN is interfering with NetExtender, because that was/is installed on both Windows 10 and Windows 11. However, it did not create a problem when it was also installed on NixOS (it was not installed on the Windows 11 VM).

The only reason I'm using NetExtender is to connect to this database, so any help solving the problem would be great. Thanks.

Category: VPN Client


  • AjishlalAjishlal Community Legend ✭✭✭✭✭


    Disable the windows Firewall and try.

  • I tried that with Window 10 and to be safe retried it with Windows 11. No change in the result.

    I do have VMware Workstation and setup a Windows 11 VM and it worked without any problems. This solution isn't ideal because I'll have to install the same programs on this VM that I normally use on the main OS and there is a noticeable performance drop.

    So Sonicwall, you're VPN software sucks.

Sign In or Register to comment.