Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".


Netextender - Error happens in tunnel negotiation v10.2.336

Hello all, we are having a bit of trouble when using netextender connecting to a Server, I'm new when it comes to VPN I hope you can help me with this. We have at least 4-5 users who have this kind of issue. Most of them use windows 10 or windows 11 and all the devices are up to date. We are all working from home, so we don’t have the same ISPs.

This is what I’ve tried so for.

·        Reinstalling all the WAN Miniport driver from device manager

·        Re-image the device (laptop/desktop)

·        Connecting to a different ISP

·        Using a VPN (Surfshark) before connecting to netextender

·        Access

https://Firewall_PubicIP:SSLVPN port (example and they access it via web using the device where they can’t connect using the netextender

·        Using a different version (old version) of netextender but we are getting a different error, so we really need to use the latest (v10.2.336).

·        Flush dns

·        Running nextender as administrator

·        Update laptop/desktop to latest version

·        Run REG ADD "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters" /v DisabledComponents /t REG_DWORD /d "32" /f via Administrator.

·        Install manually the driver for netextender


This is what I noticed on my end most of the device having trouble connecting to the VPN of the client has an Intel or Qualcomm Atheros wireless driver and while testing on my end since I am using a Wi-Fi dongle that has a Realtek driver I can connect without any problem. I found a work around for them to be able to access it by disconnecting the device from their internet connection, clear the profile on netextender and it works. I noticed as well that using a Realtek wireless driver is not going to solve the problem, we sent out one of our colleagues and it’s not working. That’s where I run a tracert to the Server where they are connecting, and I am getting a lot of RTOs so I tried to connect on my mobile data via Wi-Fi tethering using the Wi-Fi dongle on my end apparently I can’t connect so I am assuming it matter that you need to have a strong ISP before connecting to the said Server via NetExtender. I’m sure I tried more than what I mentioned above and not getting any kind of solution to this problem and I don't have access on the server part since it's a client server. Anyone who has this kind of problem too on their end? I hope you can help me with this. Thank you!

Category: Entry Level Firewalls
Sign In or Register to comment.