Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

Netextender with Windows 10 Version 2004

Kulpie6289Kulpie6289 Newbie ✭

Has anyone used Netextender with the latest Windows 10 update to version 2004? I have a normal Dell laptop that was working with NetExtender-9.0.0.274.msi. After the Windows update it will connect but no data passes over the VPN. The client gets an IP, so everything looks good from that standpoint. I tried uninstalling and reinstalling Netextender with the same result.

Category: SSL VPN
Reply

Best Answer

Answers

  • NevyadithaNevyaditha Moderator

    Hi @Kulpie6289 ,

    Can you please check if the below services are running on your Win 10 Machine :

    Remote Access Auto Connection Manager

    Remote Access Connection Manager

    Routing and Remote Access and also try to restart the service "SonicWALL Netextender service ".

    Can you confirm if the Routes are shown on the Netextender client after you are connected ?

    Please also perform Route Print on the Client connected PC to confirm if you can see the routes created in the route table which will be removed when Netextender disconnects.

    Also would like to know the below things:

    Is the client configured in split mode or tunnel mode?

    Are you trying to access the resources on the Remote site or on the Internet ?

    Have you come across this Issue with any other User ?

    Nevyaditha P

    Technical Support Advisor, Premier Services

  • Kulpie6289Kulpie6289 Newbie ✭

    Thanks for your reply Nevyaditha.

    In answer to your questions:

    Remote Access Auto Connection Manager - Not running (Set to Manual)

    Remote Access Connection Manager - Running (Set to Automatic)

    Routing and Remote Access - Not running (Set to Disabled)

    Sonicwall Netextender Service - Running all options Stop, Start, Pause, Resume, Restart are grayed out and unavailable.

    One route to the LAN is shown 10.17.11.0, 255.255.255.0 (Client IP is shown in the connect message as 10.17.11.70)

    Route Print shows the required route 10.17.11.0 255.255.255.0 thru 10.17.11.70

    Tunnel All is set to Disabled in the Default (only) profile

    Trying to access resources on the Remote LAN - Cannot Ping any nor use shared drives or SSH server

    No other users with problems, but this is the only client with this new Windows update.

    One other thing: After connection, the Netextender reports Bytes sent increasing - it got to 40,000 after a few minutes, but Received went to 274 and stopped.

    Thanks,

    Karl

  • NevyadithaNevyaditha Moderator

    @Kulpie6289 ,

    We need to perform capture on the sonicwall

    Can you configure the capture following the below KB with source IP as the IP that you got on Netextender client

    Please try to generate the traffic for the LAN resource after configuring the capture and let us notify if you see that traffic reaching sonicwall or not ?

    Nevyaditha P

    Technical Support Advisor, Premier Services

  • SaravananSaravanan Moderator

    Hi @Kulpie6289,

    As per your description, looks like possible mess up with Nx adapter on the client machine. In addition to the suggestions given previously, please try using SonicWall Mobile Connect as a platform for VPN. This can indeed help you figure out the adapter issues because using SonicWall Mobile Connect, the VPN traffic takes a different adapter path.

    Hope this helps.

    Regards

    Saravanan V

    Technical Support Advisor - Premier Services

    Professional Services

  • Kulpie6289Kulpie6289 Newbie ✭

    I'll set up a capture next.

    Saravanan, I installed the Mobile Connect from the Windows Store. It connects and gets an IP from the SSLVPN IP Pool. After that I get the same issue - no ping or shared folder access. the Received bytes in the monitor stays very low. As a matter of interest, I tryie this on a version 1904 Win 10 and it does the same thing, so I'm suspecting something in the destination Sonicwall (TZ600). However I do have other working clients at present.

    Karl

  • shiprasahu93shiprasahu93 Moderator

    Hello @Kulpie6289,

    Could you please check if the SSLVPN pool is overlapping with the LAN subnet of the firewall. It is always better to use a subnet that is not physically configured on the firewall.

    Thanks!

    Shipra Sahu

    Technical Support Advisor, Premier Services

  • Kulpie6289Kulpie6289 Newbie ✭

    Thank you Shiprasahu93, The SSLVPN Pool does overlap with the LAN address. LAN address is 10.17.11.0/24 and SSLVPN Pool is the range 10.17.11.70-79. I can't change it right now because there are connected clients working just fine. The range does not overlap with the normal DHCP range which is 10.17.11.100-199.


    I can change it tonight after working hours.

    Another interesting item. SSH on port 22 does work to a server on the LAN. SMB shares are not visible. Packet capture shows dropped ICMP packets and additional dropped packets to IPs off the LAN.

    Firewall rules seem to Allow any traffic fron SSLVPN to LAN Subnets.

  • Kulpie6289Kulpie6289 Newbie ✭

    It looks like the address overlap was the issue. After setting the SSLVPN Address Pool to a completely different range not on any connected network, it seems to work both with the Netextender and Mobile. It did require an update to the latest OS of the Sonicwall and and reboot.

  • shiprasahu93shiprasahu93 Moderator

    @Kulpie6289 ,

    Glad to hear that the issue is fixed. You have a wonderful day ahead!

    Thanks!!

    Shipra Sahu

    Technical Support Advisor, Premier Services

  • Kulpie6289Kulpie6289 Newbie ✭

    Thanks for your help.


    Karl

Sign In or Register to comment.