Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

SonicWall NSA 2700 will not provide IP address for new conference phones when connected to the LAN

We recently upgrade our Firewall from an NSA 3600 to an NSA 2700 and are having issues with connecting new conference phones to the office network. Specifically, I have a Yealink 960 hosted through 3CX. I plug the device into the LAN, and it does not receive a DHCP address. I have tried the following troubleshooting fixes:

-Connected the phone to my home LAN and it was able to receive an IP address through DHCP

-Connected the phone over our office WLAN and it was able to receive an IP address

-Tried creating a static IP address reservation on the Sonicwall DHCP server and that had no effect

-Tried setting a static IP to the conference phone, rebooted and that had no effect

-Ran a packet capture on the device and saw the phone was sending Discover packets, but it never received a response.

-The conference phones that we have currently are able to connect to the network and provision just fine

Please let me know what I should try next. I think it is some settings configuration on the Sonicwall, but I am not sure where to look first.

Category: Mid Range Firewalls
Reply
Tagged:

Answers

  • BWCBWC Cybersecurity Overlord ✭✭✭

    @solar_small you should run a Packet Monitor on the Firewall for IP, UDP, Port 67,68 and check if the DHCP Discover reaches the Firewall on the correct interface. If you can't see the Discover on the Firewall it might get caught on the way, because you checked already that the Phone is generating the Discover properly.

    --Michael@BWC

  • ArkwrightArkwright All-Knowing Sage ✭✭✭✭

    IME, when something odd happens with DHCP serving, disable/enable the scope will fix it surprisingly frequently. I have seen this with Gen6 and Gen7 firewalls.

  • solar_smallsolar_small Newbie ✭

    @BWC @Arkwright


    Hey guys thank you for the responses. We ended up fixing the issue by disabling CDP (Cisco Discovery Protocol) on the phones. After that they were able to connect to the network just fine. I am not sure why this worked, but it makes sense considering we are not on a Cisco network? I figured it would use a different discovery protocol like LLDP but I guess the phones were using CDP by default?

Sign In or Register to comment.