Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

Issue with Web Login over SSL VPN

I have an interesting issue. Recently I tried configuring SSO authentication on my NSA 2650 running SonicOS Enhanced It was not working so I eventually gave up and removed the config settings I changed. However, around this time I began having issues with Web Login over HTTPS specifically when I connect from over SSL VPN. Please note I can access the login page, but what is curious is the username field is auto-populated and cannot be changed with the format, using the username of the SSL VPN authentication. If I enter my credentials I get an "access is denied" error. This is ONLY over SSL VPN, over LAN nothing is auto-populated and I can enter my credentials just fine. It worked just fine before, and the SSO config mentioned above is the only major change I can think of in the time frame this issue began.

SSL VPN and Web Login both authenticate over RADIUS. I have been methodically looking through the Sonicwall config and simply cannot find anything to indicate why this username field is autopopulated. One thing I found and tried to no avail was at Users > Settings > Authentication > Configure SSO > Users, it was set to "Use the domain name as received", and I changed it to "Always use a consistent domain name". This did not change the behavior in any way. Please help!

Category: Mid Range Firewalls


  • TKWITSTKWITS Community Legend ✭✭✭✭✭

    My guess is the Sonicwall is auto-populating the name based on it knowing the details of the SSLVPN session. To me it sounds like your cleanup of SSO didn't catch everything, but what that is I do not know.

    It would probably benefit you to restore from a backup.

Sign In or Register to comment.