Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".


Replace Sonicwall Nsv

So, we setup a trial Nsv for an Azure deployment which is working really well. However, when we attempt to license it we came across an issue where we are unable to use a Monthly license. It will not accept it.

I have been told it will never work and need to create a new Nsv without applying a trial license. I can then apply the purchased license and reconfigure. Not ideal in teh slightest.

My issue now is that if I create a second Nsv within the Azure subscription, i can't seem to get it to use the same resource group and network. I am a bit lost now and just seem to be going around in circles.

Has anyone replaced a Nsv with another Nsv in the same Azure subscription?



Category: Virtual Firewall


  • Options
    TIJUTIJU Moderator

    hi @Vigneshkumar_S Can you take a look at this and help the user here.

  • Options
    Hello rob
    I am from Argentina and I am having a similar problem, Azure does not let me implement the NSv 270 BYOL Azure SIG. (7.1.1-7047-R5587). This update requests to redeploy a new VM. But when I run the installation from the MarketPlace it gives me an error when I indicate the same VNETs of the productive firewall it indicates an error.

  • Options
    MustafaAMustafaA SonicWall Employee

    @Alejandro_Santillan , when you try to deploy the NSv using the MarketPlace you will get an error if the resource group is not empty or if you want to reference a Vnet that belongs to a different resource group. This limitation is being worked on by our engineering team. That said, when you use the ARM Template you should be able to do both. Let me know if that works.

  • Options
    Hi MustafaA.
    First of all, thank you for answering. I used the template but it gives me an error when creating the WAN-X1 interface. I attached an image.

  • Options
    MustafaAMustafaA SonicWall Employee

    @Alejandro_Santillan , this issue seems to be a different one, not related to the resource group being not empty or using Vnet of a different resource group. I'd suggest you to call our Technical Support so that we can review and assist.

  • Options
    Dear MustafaA
    I am going to open the case, I will indicate that we were using the template that you indicated to me. If anything else can be done I would appreciate it.
    Kind regards.

  • Options
    I have good news, I was able to get the template working and the NSv270 VM was created with the Linux version (soniccorex SonicOSX 7.1.1-7047-R5587).
    The problem I found in the template is that the "Virtual Network Resource Group Name" field does NOT take the data entered, it changes it to "Subscription/Resource Group:".
    The VM was created in the same Resource Group as the current Virtual Network.
    I hope it is understood.
    Cordially greetings.

  • Options
    BlacksuitBlacksuit Newbie ✭


    Can you provide the steps you took to deploy the new NSv? I cannot find any documentation on how to perform this upgrade in Azure and it is something I need done asap. I have the same issue when using the Marketplace and need to put it on the same network in Azure as our current NSv 7.0 is located.

    Thank you for any help you can provide!

  • Options
    MustafaAMustafaA SonicWall Employee

    Hi @Blacksuit

    Please use the following ARM template.

  • Options
    BlacksuitBlacksuit Newbie ✭


    I have been on a support call with Sonicwall for the past 2 hours+ and still cannot get this resolved.

    {"customHtml":{"htmlTemplate":"<code><div>Resource /subscriptions/XXXXXXXXXXXX-a3415c459ab8/resourceGroups/NSV/providers/Microsoft.Network/virtualNetworks/NameNetwork/subnets/LAN-X0 referenced by resource /subscriptions/XXXXXXXXXXXX-a3415c459ab8/resourceGroups/NSv270/providers/Microsoft.Network/networkInterfaces/NameNetwork-SW-Interface-X0 was not found. Please make sure that the referenced resource exists, and that both resources are in the same region.</div><div>Resource /subscriptions/XXXXXXXXXXXX-a3415c459ab8/resourceGroups/NSv270/providers/Microsoft.Network/virtualNetworks/NameNetwork/subnets/WAN-X1 referenced by resource /subscriptions/XXXXXXXXXXXX-a3415c459ab8/resourceGroups/NSv270/providers/Microsoft.Network/networkInterfaces/NameNetwork-SW-Interface-X1 was not found. Please make sure that the referenced resource exists, and that both resources are in the same region.</div></code>","viewModel":null}}

    This is the exact same issue @Alejandro_Santillan was experiencing. I do not know what his solution was to resolve it, which I wished he put the solution in his response. I am now pending a callback from Sonicwall Support as this could not be resolved in the 2+ hour phone call.

    Please advise.

  • Options
    BlacksuitBlacksuit Newbie ✭

    I do find it ridiculous that there is a lack of documentation for this process when the upgrade calls for deploying a new VM in Azure without any guidance. We are a small company and lack the man hours and experience on an Azure level to implement this in a timely manner. Upgrading our On-Prem to 7.1 is causing site to site tunnel to Azure to drop or not connect at all.

    I know that this has to be affecting numerous customers, like myself. I would encourage the engineers to thoroughly document this process for Azure as we cannot just simply deploy in the same subnet in Azure using the marketplace. The template provided in the above replies fail to guide customers on how to proceed. It gives an error when trying to deploy.

Sign In or Register to comment.