Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

NetExtender - Windows Proxy - Microsoft Apps and Authentication Issues

I started a ticket with support regarding this issue, but it is good to get a conversation started as well.

After a user connects to the VPN via Net Extender then returns to the office, they are unable to use any product that uses the Microsoft Authentication Library (MSAL) for authentication. This includes the Office 365 suite, Teams, Word, OneDrive, Excel, etc... The apps behave like they don't have access to the internet. However, web versions in a web browser still work fine.

After many, many hours of troubleshooting, it was discovered that enabling then disabling the proxy setting in Windows settings fixes the issue. Restarting the computer does not solve it, uninstalling/reinstalling Net Extender does not fix the issue, uninstalling/reinstalling Office products does not fix the issue. The original fix was to reinstall Windows, then it was discovered that enabling the proxy with the settings blank/default, then turning it back off in Windows solves it. This is our current workaround, but this is a problem that needs addressed.

Category: Entry Level Firewalls


  • TKWITSTKWITS Community Legend ✭✭✭✭✭


  • RyderCragieRyderCragie Newbie ✭

    We've got the same issue. Still trying to find the root cause of it.

    Hoping to find a fix that can be done from our end rather than something that has to be done from the users end/PC. We will most likely be opening a ticket as well.

    Following this thread. Glad it's not just us!

  • James_HJames_H Newbie ✭

    We still haven't been able to connect with SonicWall regarding this. We are waiting to have a machine that comes in with the issue that we can work with for a while, so we can call in for some screen sharing / packet sniffing with SonicWall support.

    A couple of things we found:

    Often, when we would run Fiddler during the problem, the issue would go away until we closed Fiddler.

    One time, running Fiddler actually solved the problem.

    The issue is few and far between, but it has always been on Dell laptops and seems to be happening to the same people.

  • RyderCragieRyderCragie Newbie ✭
    edited March 2023

    We’re also noticing it mostly with the same people, and mostly laptop users. (But that could just be due to the fact that laptop users are more likely to use NetExtender than PC users). It seems to be people who work from home and then come back onto site. It’s at the point that they physically come back onto site that it breaks.

    These are the two fixes we're currently using. Let me know if they work for you if you get a chance to test them.

    The quickest fix we have for this is as follows:

    (The below scenarios assume the user is physically on-site).

    1. Close Outlook.
    2. Disconnect from corporate/internal network.
    3. Connect the user's machine to a mobile personal hotspot (to simulate working from home).
    4. Connect to NetExtender.
    5. Open Outlook and let it connect and pull through new emails.
    6. Disconnect from the mobile personal hotspot.
    7. Connect back to corporate/internal network.

    The alternative, but longer, fix is as follows:

    (Rebuilding the Windows profile).

    1. Log out of the user's Windows account.
    2. Log in as administrator.
    3. Navigate to C:\Users and append "_old" to the name of the user's home folder.
    4. Open regedit.exe as an admin and navigate to the following key: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList
    5. Delete the user's Windows profile from the "ProfileList" key.
    6. Log out of the admin account.
    7. Log in as the user and let the new profile build itself.
    8. Open and configure Outlook.

    We have also tried the following which do not resolve the problem:

    1. Reinstalling Office completely.
    2. Repairing Office (online and offline).
    3. Resetting the internet options (cache).
    4. Uninstalling antivirus.
    5. Connecting to a hotspot without NetExtender.
    6. Accessing firewall link via a web browser (sometimes this get's the machine talking to the firewall properly).
    7. Removing the account from "Work Or School" Settings and then re-adding the profile - This gives a 404 error once you try and re-add the account.
    8. Running Microsoft's own SARA Diagnostics repair tool (No faults found).

  • RyderCragieRyderCragie Newbie ✭
    edited March 2023
    Update: we’ve just had another user with this issue and reinstalling NetExtender fixed it. This has also occasionally fixed it in the past.

    We’re now certain this is a NetExtender issue and SonicWall will need to push out a new version to fix it.
  • James_HJames_H Newbie ✭

    just curious... Have you tried the method of enabling then disabling the proxy in Windows network settings?

    In our experience, just enabling, saving, then disabling fixes it. I would still point to NetExtender as well.

    Settings -> Network & internet -> Proxy "Set up" -> toggle the Use a proxy server button, Save -> Then untoggle and save.

  • RyderCragieRyderCragie Newbie ✭
    Tried that one 1 machine. Didn’t work.
  • Good morning.

    I had asked one of our senior development users to test our SSLVPN using NetExtender and 1 day later, he was unable to connect to any of the 365 resources. Attempted uninstall, resetting local network equipment, etc.

    Finally, what solved it was from Windows 10:

    Control Panel > Internet Options > Advanced > Reset

    This could be incredibly impactful to a support team if they are supporting many users.

    This doesn't instill confidence in Sonicwall solutions when users are the ones solving the issues.

    Thanks to the community here for the fix.

  • Has this issue been resolved yet with an update to NetExtender? I am still having to resolve this for users occasionally.

    This is what I've been doing to fix. Fully exit out of any Office 365 apps, Teams, and Onedrive

    Windows 10 fix: Reset Internet Explorer Settings and DIsconnect Work & School Account (Microsoft/Office 365, not Domain AAD Account), Open an app and log back in.

    Windows 11 fix: Reset Internet Explorer Settings. (Since they hid the reset option, you can run RunDll32.exe InetCpl.cpl ResetIEtoDefaults in CMD, DIsconnect Work & School Account (Microsoft/Office 365, not Domain AAD Account), Open an app and log back in.

  • PatricePatrice Newbie ✭

    I removed Netextender from my computer and use 'Mobile Connect' from MS store.

    Work well for now.

    I don't know if that solution work fine for domain users, we only use it for Linux servers access.

  • PatricePatrice Newbie ✭

    Not sur if SMA-4728 Mean that the problem is fixed or not

Sign In or Register to comment.