Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".


NetExtender - EPC Agent Failed to Install

AdamFAdamF Newbie ✭
edited December 2022 in VPN Client

Hello, I have one windows 10 laptop that receives this error when connecting to one of our SMA 410 appliances. If they connect to the other two SMA appliances it works fine. I had him try downloading the client directly from the SMA 410 and uninstall/reinstall the NetExtender Client, still same error. Not sure what else to have this particular user try, and googling this error returns no results and searching this community for this error also has no results.

Category: VPN Client


  • Options
    Alex_BAlex_B Newbie ✭

    Hello, we are getting the same issue across a large amount of Windows 10 clients now after upgrading to the 10.2.331 NetExtender client. We are also running an SMA410 on firmware version

    We had to disable EPC right now to allow our users to connect. Have you found any resolution to this yet?

  • Options
    StefanAStefanA Newbie ✭
    edited January 2023

    Hi, we're having the same error on new clients - slightly different message: The downloaded NetExtender installer cannot be validated. Please make sure that you are connecting to a trusted SSL VPN server.

    Already installed clients are still working here.

    We also got a SMA410 but running on a older firmware version, which we are about to upgrade. So older versions are affected too.

    I found this in the knowledge base, but it didn't help us:

    Maybe you are more lucky, but the given reason there in march 2020 was windows updates.

    If someone from sonicwall could point one which updates, that would be nice.

    As a workaround we just disabled EPC for the new users, so everyone else still got this feature:

    Users -> Local Users -> Edit User -> Tab EPC -> Enable EPC => Disabled

    Our error message:

  • Options
    AdamFAdamF Newbie ✭
    edited January 2023

    There's a new knowledgebase article posted 1/4/23 about this issue here: EPC agent fails to install. | SonicWall but EPC license is saying expired (it's not supposed to expire our other units are still showing good through 2068). I called support today and they confirmed it's a bug. Waiting for sonicwall engineering to hopefully fix the bug. (You can bypass the issue by disabling Endpoint Control). It's because they're making some backend changes to licensing and EPC is moving to be part of base license, but some units are wrongly showing expired and it's causing this issue for clients when they connect. Hope to have the issue resolved soon.

Sign In or Register to comment.