Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

370W IPS causes way to much latency for NAS access and/or movie playback across LAN

Just installed a new 370W and found a major issue with IPS turned on, all my access on my LAN behind the firewall is way to latent/slow.

Playing movies off the nas lags and stutters and drops, using an old box that uses old smbfs is also painfully slow across the network.

My old security device with IPS worked fine, and performance on the lan was normal.

Is there a bug in the firmware with IPS? Is there a way around this?


Thanks!

Category: Mid Range Firewalls
Reply

Answers

  • jtuckerchugjtuckerchug Newbie ✭

    hello. perhaps you could add exceptions for these resources. if you trust them then it should not pose a problem.

  • MwebberMwebber Newbie ✭

    Thanks for the good advise. I tried that and even turned IPS off totally. It is much much better, but I'm still getting to much lag on the lan.

    The only think I have on is geo blocking. I will try turning that off.


    Could my 3 gigabyte switches (unmanaged) be causing such problems? I will enable LAN on the X2 and X3 and see if that helps. My old Unify USG didn't have any of these issues in this network. Not sure why I am now...

  • TKWITSTKWITS Community Legend ✭✭✭✭✭
    edited August 31

    If the client and server devices are on the LAN than the traffic should not be flowing through the Sonicwall. That is unless you are portshielding or VLANing with it...

    Provide more information about your setup. Ubiquity and Sonicwall products are of different leagues.

  • MwebberMwebber Newbie ✭

    Sure, thanks:

    I was getting desperate and was going to enable X2 etc as a lan, but based on your recommendation I will not.

    I have a Spectrum Cable with EU2251 Cable modem. I own 360 mps download speed. The speed tests show normal ranges always around 360 even with IPS - Virus - Malware - turned on.

    Next it goes directly to the Sonic Wall 370W. I have had a handful of techs from SW run tests and log etc and they said the 370 is good. Right now I have everything turned off except geo blocking with a handful of continents in the list.

    X0 goes directly into a D-Link DGS-1024A gigabit unmanaged switch with a bunch of computers with different operating systems some with older standard linux smbfs connections, a QNAP NAS (has media files on it), and a wifi bridge (linksys). Probably around 7 computers wired directly to the switch.

    The D-Link goes to another floor and a plugs into a 4 port intellinet gigabit unmanaged switch. From there a longer run (25 Ft) go another D-Link DGS-1024A where a few computers and a X-box are plugged into.

    I setup the WIFI on the SW and half of the wifi devices plug into that the Linksys supports the Roku (since it is older and needs 2.4 connection).

    Lan performance with any setting has been dismal, where movies stutter when being played from the qnap, older smbfs connections drop and are not constant (seems they are very sensitive to latency from what other have told me). At times my windows 10 box won't see files until you refresh everything.

    Wan performance and getting out to the internet is also sketchy, Lag when surfing in general. When I'm using Teamviewer it occasionally drops connection.

    I ran the entire network off the linksys wifi router without the SW 370W and everything worked well both on the lan and wan.

    I hope this is enough info...

  • MwebberMwebber Newbie ✭

    I will also mention that with IPS turned on. None of my older systems can even connect to the NAS and media playback is even more reduced in playback quality. Turning IPS made a big difference, but didn't as I mentioned above really fix anything by making the network useful.

  • MwebberMwebber Newbie ✭

    Turned off GEO Blocking, now everything appears to be off.

    Performance is the same sadly, stuttering media playback and slow lan performance.

  • MwebberMwebber Newbie ✭

    I moved switches around and unplugged my NAS no change in results.

  • MwebberMwebber Newbie ✭

    I worked with support and portshielded a few computers and servers directly on the sonicwall and removed the rest of the network.


    Everything worked fine with no latency. I assume my switches or wiring is to blame?

  • TKWITSTKWITS Community Legend ✭✭✭✭✭

    That would be a good assumption. Time to pin point the issue by connecting devices one by one...

Sign In or Register to comment.