Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

SSO Agent errors

AdviseAdvise Newbie ✭
edited August 17 in Mid Range Firewalls

I recently noticed that I'm getting some different alerts in my email related to the SonicWall SSO service.


In my network I have machines with Windows XP and W7 in a different VLAN from computers with Windows 10 (only Windows 10 has full access to the internet).

I have a Firewall SonicWall NSA 2600 + HA and two servers running (redundancy) SSO Agent version 4.1.6.

Checking the SSO agent settings, I notice that it is unable to connect with the domain controllers. I tried to solve this problem by enabling the ports mentioned in another SonicWall KB but it didn't work.

On one of the servers running the SSO Agent, I tried to install the latest version of the Agent that I found on mysonicwall.com. When will I run the setup process. I get this error:

apparently all the necessary settings and ports are open, but nothing makes this agent communicate with the server.

When we access the SonicWall SSO configuration menu, we can perform a connection test with the agents and everything works perfectly. But when we checked the email report, we noticed the errors in the first image of this text.


Has anyone experienced this and had a solution?

Category: Mid Range Firewalls
Reply
Tagged:

Answers

  • AdviseAdvise Newbie ✭

    apparently this colleague has or had the same problem as me, I will try to look for an older version of the SSO Agent to test and see if I can configure it on my server.


    https://community.sonicwall.com/technology-and-support/discussion/3967/sso-to-edir-upgrade-fails-ip-to-user-connection

  • AdviseAdvise Newbie ✭

    I installed version 4.1.6 and the error persists.

    During the installation you are asked to fill in the domain name, an account with Domain Admin access and the account password.

    Then the Appliance IP and a password for synchronization.

    After filling all this, the error appears and the application does not open correctly.



  • JimmywickJimmywick Newbie ✭

    SSO agent reported: OS Error -21477217406: This error is typically caused by a WMI failure. When no user os logged in, WMI gets a response as "getFields failed" which is represented by SonicOS as a negative number. This is not indicative of a user identification failure.

  • AdviseAdvise Newbie ✭

    @Jimmywick I didn't get this error at any time. The errors that often appear to me in emails are those shown in the first image.

Sign In or Register to comment.