Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".


Link Aggregation (LACP) with Windows Server 2019

OlivermmOlivermm Newbie ✭

Hello !

I was trying to set up a link aggregation in LACP mode between my SWS14-24 and a Windows Server 2019.

On the Switch (Firmware

I created a "port trunking" with the member ports and mode = LACP

On Windows Server:

I created a NIC-Teaming also in LACP mode.

On our previous switch devices (HP), this was the way it works. Now Windows Server is saying that there is a LACP-negotiation error. I also changed the LACP Timeout at the Switch from Long- to Short-Timeout, but that makes no difference at all. Does anyone have experience with that ?

Category: Switches


  • Options
    MarkDMarkD Cybersecurity Overlord ✭✭✭ pages 47 and 48 cover Link aggregation and Port trunking.

  • Options
    OlivermmOlivermm Newbie ✭

    Hi @MarkD,

    I fully paid attention to the administration guide and documentation, it won't work.

  • Options
    TKWITSTKWITS Community Legend ✭✭✭✭✭

    Are both the server and switch set to Dynamic LACP?

  • Options
    OlivermmOlivermm Newbie ✭
    edited August 2022

    @TKWITS I don't see there is an option to setup a "dynamic" LACP on the switch. For setting up a port trunking, there is only the option between static and LACP. The "dynamic" option on the server is an option for load balancing between the single links within the aggregation. On the switch, you haven't a load balancing option, only a system policy. I think the system policy is more a kind of a QoS thing, not for load balancing.

  • Options
    TKWITSTKWITS Community Legend ✭✭✭✭✭

    Per the Admin guide, if the switch Port Trunk is set to LACP than it is in dynamic mode.

    You have to match the server and switch configs, thus the server needs to be in dynamic mode as well.

    See here for a powershell command that may help you:

Sign In or Register to comment.