Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

USB Device Control Problems

xdmfanboyxdmfanboy Newbie ✭
edited February 14 in Capture Client

Running 3.6.34. I started to play with this feature and am disappointed so far. My big issue is the very long time the policy changes take to go into effect, and am wondering if I am doing something wrong, though pretty sure not since the policy eventually took effect. First, I added a policy to block all USB devices. No effect, recognized anything I plugged in, even after doing an apply policy change from both Capture Client and Capture Client Management. Messed around for awhile, gave up for the day (Friday) and on Monday happened to reinsert the thumb drive to actually use it for something, and voila, blocked with pop-up from CC! Okay, got back to play, using the device info in the log, did an allow of that device based on its serial number. No dice, even after applying policy from client and management side. Tried it also by vendor and product IDs, still no love on Valentine's Day. I suspect later tonight or tomorrow it may take effect, but that is totally unacceptable. (update - worked 45 min later when I tried - still unacceptable) If a manager needs to whitelist something for a user it needs to take effect NOW, not tomorrow! Help!

As a related question, without involving device control at all, doesn't Capture Client have the smarts to scan a USB storage device that gets plugged in? If it can't then that's pretty sad, as that's been a basic function of antivirus programs going back 20+ years. If it can scan the device then what's the point of device control, since Capture Client has it covered?

Category: Capture Client
Reply

Answers

  • ThKThK Cybersecurity Overlord ✭✭✭
    edited February 15
    @xdmfanboy your post is so welcome! I have activated usb blocking for a long time . It never was that perfect solution the time til a new usb stick could be configured and updating the policy was sometimes a mess. For a new usb i was not able to add it on a homeused notebook of a secretary. So time was money i must disable this function to get her to work.
    Yesterday i had same with the ceo who has a new stick in use. Found the sick in the logs and set to allow . But it keeps blocking this new stick.
    With your experience here i must confirm i now noticed both pcs are using 3.6.34

    older versions didnt have this issue !

    —Thomas
  • xdmfanboyxdmfanboy Newbie ✭

    Ah, so they broke it! I hope they're aware of the issue, as I don't feel like going thorugh the pain involved in contacting support.

  • ThKThK Cybersecurity Overlord ✭✭✭
    I got an reply from this guy : also i switched off the policy only all former well known usb sticks could be used. I had the idea that cc then ignores the devicesettings and he could use the new stick . but i failed.
    Cc seems to igore the policy updates for usb control since 3.6.34

    —Thomas
  • xdmfanboyxdmfanboy Newbie ✭
    edited February 17

    I had some back and forth with support. They were not aware of problems with policies updating in 3.6.34, but offered to work with my setup to investigate. He did state that changes can take up to an hour, and when I asked if this was true even when clicking Update Policy on the client side his response was ambiguous.

    Also, I asked what is the behavior of CC when you plug in a data device, with no device control configured. As I hoped to hear, Sentinel One will monitor the device for malicious activity, basically fully protect. Then what, may I ask, is the point of even blocking USB devices if they can't spread malware anyway?

    His first response:

    "Also for the second question when you insert the USB data source into host capture client will not scan the USB drive but SentinelOne sits on the Drivers of the USB and all peripherals, if a malicious activity is found either by cloud intelligence or background process it will be blocked by capture client hence will keep the host protected."

    After I asked for clarification on some points:

    "Also for the second question even when you insert the infected host your endpoint will be secured because if the infected endpoint does any malicious activity the sentinelOne cloud intelligence will block it and also you can run the manual scan as well."

    Hope this helps.

  • ThKThK Cybersecurity Overlord ✭✭✭
    any updates on this behavior?

    I will add that my usage off the usb blocking is to have an overview about the usage of unconsolidated and unallowed media
Sign In or Register to comment.