Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

TZ570 Will not upload new firmware because it thinks its not regitersered

I have a TZ570 on v7 that needs a firmware upgrade. This firewall is in a secure environment and does not have internet access. It was registered in MySonicwall before being deployed over a year ago. When I attempt to upload new firmware, I get an error message that says to register the firewall first, which it already is. But I have gone through the process to manually register a couple of times and it still does not recognize that its registered, authentication codes match also.

This is the manual registration process I am following is here:

Has anyone seen this issue before?

Category: Entry Level Firewalls
Reply

Best Answer

  • CORRECT ANSWER
    prestonpreston Enthusiast ✭✭
    edited January 27 Answer ✓

    Hi JimAllenSW , do you have the Reg code? (you may not need it if you imported the license keyset) if so you can go to the Diag page /sonicui/7/m/diag

    disable the SonicUI7 as default management GUI

    then save settings, then re-login to the firewall ,you will need to take anything after the port number out of the url first

    once logged in just go to the setting page it will ask you for the reg code if it is missing enter the code, upload firmware , then go back in to the Diag page (the Gen6 one then re enable the option you disabled earlier and then save the settings, log back in again and upgrade the firmware.

Answers

  • JimAllenSWJimAllenSW Newbie ✭

    Hi Preston,

    Thanks for the response! I will definitely try this and am sort of familiar with the reg key process from the 6.5 UI. Do you know if this requires a reboot, either disabling/enabling the SonicUI7 or entering regcode? I just need a business maintenance window if it does. I was caught by surprise when I uploading the manual keyset, the firewall rebooted on its own!

    Thanks,

    Jim

  • prestonpreston Enthusiast ✭✭

    JimAllenSW yes it will will require a reboot as things like the SSL VPN clients may not be able to connect until you do so I have found,

    It would be best waiting until you are ready to to the firmware upgrade as it reboots anyway as part of the process, so if the reg code is already visible in the Gen7 Dashboard then you won't need this when swapping over to the Gen6 GUI, upload the firmware then back to the Diag page (gen6 /diag.html) and then go back to the Gen7 GUI then boot firmware with current settings,

    if you wanted to boot the firmware with FD then you could just leave in the Gen6 GUI as when it does FD it will revert back automatically to the Gen7 GUI after the upgrade

  • ArkwrightArkwright Enthusiast ✭✭

    You can update firmware in safe mode if it isn't registered.

  • prestonpreston Enthusiast ✭✭

    @Arkwright , this is Gen7 JimAllenSW is talking about, depending on the current firmware version you cannot even get in to safemode without the appliance being registered and you need the Maintenance Key, even later versions it will let you use the Auth Code but that is only with an already factory defaulted appliance otherwise you will need the Maintenance key.

    before Gen7 you are correct you could go to the safemode without registration

  • JimAllenSWJimAllenSW Newbie ✭

    I appreciate the response. I am remote to this firewall which is protecting critical infrastructure and I can only request small maintenance windows. I can't so safe mode remotely, nor would I want to if I could!

  • ArkwrightArkwright Enthusiast ✭✭

    I could have sworn I did this with a TZ370 that I couldn't get registered. But if they've removed this ability with later versions, then that explains that.

  • ArkwrightArkwright Enthusiast ✭✭

    Found in my notes that i used

    (config-license)# register-code XXXXXX

    to do this from the CLI, not safemode.

    Sorry for the noise!

  • JimAllenSWJimAllenSW Newbie ✭

    Preston thank you!!!! Switching to the Gen 6 gui allowed me to upload the firmware!!

    BTW how do you tag someone in these posts?

  • prestonpreston Enthusiast ✭✭

    @JimAllenSW , no problem , to tag someone you just use "@" then start typing their name

Sign In or Register to comment.