Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

Sonicwall Mobile connect with MacOS Monterey

Hi,

I've come across a couple of users who have upgraded their Mac Software to to MacOS Monterey and since doing this the sonicwall mobile connect application fails to connect.

I was wondering if anyone else has seen this issue and has a fix?

Thanks

Category: VPN Client
Reply

Answers

  • AjishlalAjishlal All-Knowing Sage ✭✭✭✭

    Hi @jodybrookes

    After the MacOS upgrade, did you try to reinstall the Sonicwall mobile connect? if its not try and let us know the status.

  • Hi. I've also had this issue - Mobile Connect doesn't connect since I've updated to Monterey. I reinstalled but it's still not working. I have attached my log. Is there anything else I can try?

    Thanks,

    Jon


  • Hi,

    I'm still have this issue at the moment. I have a case open with sonicwall (43817940) about this. Both users who have this issue have tried re-installing mobile connect and was also asked to disable TLS 1.3, 1.1 and 1.0 on the SMA device but this has not worked.

    I think maybe there's a compatibility issue with the current version of mobile connect and MacOS Monterey and sonicwall need to fix and update mobile connect for this issue.

  • Hi,

    Any update on this issue? We also have a Monterey client who can no longer use the latest Mobile Connect client after the OSX update. The Mobile Connect client has been reinstalled.


    Thank you.

  • Hi @envisionitworks

    I've had the below reply from sonicwall. I haven't had a chance to try this with my users as need to get hold of them. You could try this and let us know here if it helped.


    Can you please have the user try disabling Private Relay (System Preferences > Apple ID > iCloud > Private Relay).

    macOS Monterey comes with a new feature called Private Relay which routes traffic through an Apple relay so your Mac has different IP address as seen from the WAN side. The aim of this is to protect your privacy. However, VPN services can be confused by the changing IP addresses.

    Also see https://support.apple.com/en-us/HT212614

  • cjlotzcjlotz Newbie ✭

    @jodybrookes I'm a South African user where Private Relay is not even available and I'm also running into the same issues with not being able to connect since the Monterey update.

  • TX_ITTX_IT Enthusiast ✭✭

    I wonder if the key here might be what system is at the other end of the VPN connection? Firewall, SMA100 series, or SMA1000 series? This is working okay for me with an SMA 410 on version 10.2.1.x.

  • aangeliaangeli Newbie ✭
    edited December 2021

    The same issue at me. Since MacOS Monterey SonicWall Mobile Connect doesn't work on Mac.

    But !!!!!!, on my iPad, the SonicWall VPN app works fine! That means for me: nothing changed at my company's firewall.

    (The private relay - mentioned above - turned off)

    Sonicwall, 😴wake up please and do something!

  • Reinstall doesn't work. It seems to be an issue with AV vendors conflicting with the software.

  • Hi,

    In our case we'd tried a re-install which did not help. I've not been looking at this issue myself but my colleague has told me one of the users said there was another update to macOS 12 and since updating this their sonicwall mobile connect worked again.

Sign In or Register to comment.