Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

SonicOS-API 6.5 Geo-IP

CTaylorCTaylor Newbie ✭
edited October 2021 in Developer Hub

Is there an issue with the /geo-ip endpoint?

I am able to get this endpoint to work as documented for 7.0 devices but cant seem to get it to work in 6.5 with documentation.

Using a TZ300 on SonicOS Enhanced for testing but have looked at other models/firmware and seems to be the same.

If I try to follow the links to API documentation it takes me to 7.0 documentation but that doesn't work.

If I use an older firmware version in the URL I get the 6.5 documentation but the endpoint is not working as expected.

GET is not returning all fields listed.

Example of missing data:

  • geo_ip/block/connections
  • geo_ip/block/database_not_downloaded

PUT unable to set with body documented

    "geo_ip":  {
                   "logging":  true,
                   "block":  {
                                 "connections":  {
                                                     "all":  true
                                 "countries":  {
                                                   "unknown":  false
                                 "country":  [
                                                     "name":  "Anonymous Proxy/Private IP"
                                                     "name":  "Satellite Provider"
                   "custom_list":  {
                                       "enable":  true,
                                       "override_countries":  true

Am I just doing something wrong or is there an issue with this endpoint/documentation on 6.5 or this firmware version?

Category: Developer Hub


  • JaimeJaime SonicWall Employee
    edited October 2021

    Hi @CTaylor,

    I’ll take a deeper look tomorrow, but from a quick test on my end using a TZ 400 running, I am seeing those items you noted were missing in your firewall’s response data. That was the case until I disabled Geo-IP. From then on, I am missing some of the expected data in the response—even after re-enabling Geo-IP.

  • JaimeJaime SonicWall Employee

    Hello @CTaylor,

    Even after working with the firewall for a while and subsequently rebooting it, I couldn't get the API response to include the missing details. I was very confident I saw the details previously in the API response as I mentioned yesterday, but now I'm questioning my sanity 😃. I reported the behavior to our Engineering team.


  • CTaylorCTaylor Newbie ✭

    Thank you for looking into this issue @Jaime. I anxiously await a resolution.

  • JaimeJaime SonicWall Employee

    Hi @CTaylor,

    Engineering addressed the issue and targeted the fix for an upcoming 6.5.4.x Maintenance Release.



Sign In or Register to comment.