Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".


High RDP latency thought NSa 4650


Since we buy our NSa 4650, we have a issue with RDP. (This is not related to Bookmark) Latency is instable and so high then its really annoying to use RDP. Although, latency from ping is always under 3ms. No VPN, No WiFi, Only Cooper and LAN network. I really think there is something in the NSa 4650. There is my test:

Setup 1:

RDP Client -> Router -> NSa 4650 -> RDP server

High Latency on RDP, ping Latency under 3ms. No other services seams impact.

Setup 2 :

RDP Client -> Router ->RDP server

Everything Fine, RDP working just like I was on My computer

Setup 3

RDP Client -> Router -> Router -> RDP Server

same result as Setup 2

In the NSa 4650, everything look ok (CPU, interface throughput, Memory, etc) I also try to disable security feature and put them on ''Performance optimized''. I route from LAN zone to LAN zone. I tried to lower MSS and MTU on router, Serveur, Client and NSa 4650, but nothing better... Throughput test with Iperf3 show almost 1Gbps.

My ''Router'' (Ubiquiti ER-8XG) are Basic configured, no active Firewall in them.

Category: High End Firewalls


  • Options
    SaravananSaravanan Moderator


    Thank you for visiting SonicWall Community.

    I would like to try one more setup if possible for you to narrow down further.

    Setup 4:

    RDP Client -> NSa 4650 -> RDP server

    Could you please try this setup and try the RDP access? Please initiate pings to NSa 4650's LAN interface IP and to the RDP server's IP from the RDP client and make a note of the ping response time. Please let me know.


    Saravanan V

    Technical Support Advisor - Premier Services

    Professional Services

  • Options
    jess_gagnejess_gagne Newbie ✭

    Thanks for the quick reply and sorry if my English is not that good.

    Setup 4 : Result

    RDP Client -> NSa 4650 -> RDP server

    Works perfectly... But, for this test, there something different on Layer 3.

    Setup 1 to 3 have the same Layer 3 configuration :

    Client in -> Routeur -> -> NSa 4650 -> -> RDP Server in

    I'm doing this in first place for security reason and easy configuration/understanding for non high level networking guys. I think, routing like OSPF is to hard to understand and configure for our network size. I also want to send "all" trafic to the NSa 4650 for security inspection and control. So I don't want to add route to bypass the Firewall.

    In Setup 4, I had to make a new Network in My NSa 4650. So the Layer 3 Result look like this:

    Client in -> NSa 4650 -> Server in

    Its look like the NSa 4560 doesn't like routing/redirect trafic from to If it can Help, when I make Traceroute, the NSa 4650 never Reply but I can ping it :

     1   *    *    *   Request timed out. (Should be

     2   3 ms   2 ms   2 ms (router)

     3  21 ms   4 ms   4 ms (My PC)

    Réponse de : octets=32 temps=3 ms TTL=63

Sign In or Register to comment.