Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

Incoming e-mail to aliases suddenly being blocked

We've discovered that any incoming e-mail to aliases (set up in Exchange as aliases to an e-mail box) is being blocked. The blocked connections are not showing in the Connections list in the e-mail security appliance. It's like they never occur.

Here is what comes back in the bounces:

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

  [e-mail alias]
    host [hostname of emailsecurityappliance] [ip address]
    SMTP error from remote mail server after RCPT TO:<[e-mail alias]>:
    550 5.7.1 Unable to deliver to <[e-mail alias]>
 

I've tested with several different e-mail aliases for 2 different Exchange e-mail boxes, and get the same error on all of them. Mail is delivered normally for the main e-mail addresses.

Category: Email Security Appliances
Reply

Best Answer

  • CORRECT ANSWER
    TrevorTrevor Newbie ✭
    Accepted Answer

    OK, I checked the usermap.xml file, and the aliases are in it. I tried sending e-mail to a couple of them again, and they are no longer bouncing.

    So my theory is that things were messed up in 10.0.10.6219 and then it took a while for them to be straightened out again after the installation of 10.0.10.6287.

Answers

  • BWCBWC Cybersecurity Overlord ✭✭✭

    Hi @Trevor I guess you're running 10.0.10 at the moment? The first release of 10.0.10 got pulled immediately because of AD issues.

    You should check Manage -> System Setup -> Server -> Advanced, scroll down to Misc Settings, select Data Directory at Type of File and select usermap.xml from "Choose specific file" ... that file holds all e-mail addresses the ESA knows about and considers to be valid.

    If your aliases are not in there and you did not changed anything on your Exchange, best of luck. It took SonicWall from July 2020 up to May 2021 to have LDAP related issues fixed, but they provided a private build in January 2021. This happened to OpenLDAP deployments, but if AD is not working anymore reliable, probably hell breaks loose.

    I'll monitor this thread with concern and hope for the best.

    --Michael@BWC

  • TrevorTrevor Newbie ✭

    Yes, it's currently on 10.0.10.6287. I upgraded it from 10.0.10.6219 on 5/14. It may have been occurring on the earlier build as well, but we didn't notice it until after the latest. (10.0.10.6219 was installed on 5/3.) It does however look like the last e-mail I received at one of the aliases attached to mine was 5/2.

    Nothing was changed in Exchange. I'll check out the usermap.xml file.

  • BWCBWC Cybersecurity Overlord ✭✭✭

    @Trevor what a relief, that is what I was hoping for and the reason why the first release of 10.0.10 got pulled so fast.

    --Michael@BWC

Sign In or Register to comment.