Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

SonicOS 7: DDNS on secondary interface in combination with Failover not working properly

I have a failover with X1 and X2. X2 is the secondary option. When I configure DDNS on X2 with the option 'Let the DDNS provider detect the IP address' (because I am behind an external modem), the DDNS provider sets my X1 ip.
to me it seems that the Failover setting somehow has precedence over the setting to which interface the DDNS name should be bound.
Category: Entry Level Firewalls
Reply

Answers

  • AjishlalAjishlal All-Knowing Sage ✭✭✭✭
    edited May 1

    Hi @Teleporter

    In this scenario, You have to choose the DDNS bound to interface is "ANY" instead choosing X1 or X2.

    Try above settings and let us know.

  • TeleporterTeleporter Newbie ✭

    Dear @Ajishlal

    Thanks for your response. In my scenario, I have different external modems with dynamic behind X1, X2 and X3. In order to connect to these Interfaces from the Internet, I absolutely need the "Bound to" setting to work in any of the Failover-Settings.

    This was working perfectly fine in SonicOS 6.5 and before :-( and I would love to hear of a workaround or hotfix for this.

  • AjishlalAjishlal All-Knowing Sage ✭✭✭✭

    Hi @Teleporter

    I am also using SonicOS7 and its working fine for me.

    Firmware version: SonicOS 7.0.0-R906


  • TeleporterTeleporter Newbie ✭

    Hi @Ajishlal

    I know this works when using only one entry in the list of DDNS. What does NOT work is having two DDNS entries, one for X1 and another fo X2. I need this because both Interfaces are connected to external modems.

    It seems to interfere with my Failover policy which prefersx X1 over X2 when connecting to the internet

Sign In or Register to comment.