Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

Global VPN over a slow link affecting internet access

Hi.

We have a remote working using Global VPN client, and when the VPN is connected internet access is dead slow. The user is very remote so the tunnel itself is quite slow and i accept there is bandwidth limitations. That said, Ive made sure ive set the Set Default Route as this Gateway unchecked so that the remote user is using their local gateway route which i can confirm is working. But i think the issue is more related to DNS queries which is happening over the link as the DNS server assigned by the VPN DHCP pool is at the VPN end.

I will need to send some DNS queries over the link (ones intended for the local domain) but ideally other DNS queries would use the locally assigned DNS server for the remote user. Im thinking a dirty hack for this one person would be to throw some hosts entries into the local PC but i cant workout how to set static IP address for this specific client the global VPN client so that i can use a different DNS server.


There might be a better way to do it, any ideas


Pete

Category: Entry Level Firewalls
Reply

Best Answer

Answers

  • TransminTransmin Newbie ✭

    ok think i might have come up with something. On the global VPN adaptor on the PC ive just set fixed DNS Servers (left IP dynamic) and set 8.8.8.8 as primary and corporate as secondary. Think that should do the trick. Or any other better ideas?

  • shiprasahu93shiprasahu93 Moderator

    @Transmin,

    Yes, that should work but then this needs to be done to all VPN clients. Instead, I would suggest editing the DHCP scope on the SonicWall used for GVC to use the global DNS servers.

    If the GVC clients are getting IP from X0 subnet itself and you want only the GVC clients to get the global DNS servers, you can add a separate DHCP scope for them and mention the DNS server there.

    Please refer to this kB below for creating a separate DHCP scope.

    The DNS servers can be set on the scope as shown in the screenshot below.


    I hope that helps. Thanks!

    Shipra Sahu

    Technical Support Advisor, Premier Services

  • TransminTransmin Newbie ✭

    Hi. Thanks for that. I will implement that instead of locally on each client.

    So thats helped DNS resolutions, but its clear that the downloads are still coming via the tunnel, but uploads are using the local gateway. See attached screen shots of speedtest with VPN ON and OFF. Also status page showing default traffic tunnelled to peer is disabled. Any ideas?


  • TransminTransmin Newbie ✭

    Im wondering if the issue is that the clients local network is the same IP range as the remote network. See the client route table.

    The local IP address on the LAN is 192.168.1.68 and the VPN ip address is 192.168.1.103.


  • shiprasahu93shiprasahu93 Moderator

    Yes, that can be definitely related, The end machine will be confused about what traffic needs to go over the VPN and what traffic needs to be sent through the local adapter.

    Do you have any test client that is not on the same IP subnet? If yes, could you please test once from there?

    Thanks!

    Shipra Sahu

    Technical Support Advisor, Premier Services

  • TransminTransmin Newbie ✭

    Hi. I do, but the issue is the other clients internet speed and throughput to the remote end is the same, so there is no difference in speedtest results. I will ask the client to try to hot spot on their phone as that will have a different subnet as the remote end.

  • MitatOngeMitatOnge Newbie ✭

    Hi @Transmin


    You must the change GVC VPN interface ip adress. This configuration isn't correct. Remote user network ip and Sonicwall VPN subnet must be different. after change the vpn interface ip address, problem will be resolve.

  • TransminTransmin Newbie ✭
    edited April 2
    Hi. This was the issue. RSC

    https://www.sonicwall.com/support/knowledge-base/gvc-degraded-internet-throughput-from-local-isp-even-though-connected-in-split-tunnel/200423032255090/
Sign In or Register to comment.