Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

Global VPN will not install because of older version

gsittongsitton Newbie ✭


I had 4.9.9 installed and I uninstalled it through Control Panel.

After the reboot it was still there but wouldn't uninstall as it couldn't find the uinstaller.

I downloaded the Sonicwall uninstaller, ran it twice. It removed it and now when I run it, it doesn't find it anymore.

Search Registry and deleted about 40 Global VPN entries

When I go to install 4.10, it's still telling me 4.9.9 is installed.

What else can I do?


Category: SSL VPN

Best Answer

    AjishlalAjishlal Community Legend ✭✭✭✭✭
    Answer ✓

    Hi @gsitton

    The EXE you download from SonicWall is actually a self-extracting archive. If you change the extension to .ZIP, you can open the archive and you will see 2 files, RunMSI and GVC Installer - RunMSI is what gives the "already installed" message - extract and run the GVC Installer file and run that, it should install the client.


  • LarryLarry All-Knowing Sage ✭✭✭✭


    You can try using this Microsoft utility:

    Run it for Uninstall and if Global VPN is not listed, select the "it's not on the list" option. After it is done with cleanup, reboot.

    Try the installation after that and update this thread with your status.

  • gsittongsitton Newbie ✭


    Thanks, but that didn't work,

    It asked for a product code, which when I ran the uninstalled it showed me so I used that.

    Same issue, won't install as it detects another version.

  • AjishlalAjishlal Community Legend ✭✭✭✭✭

    Hi @gsitton,

    use Revo Uninstaller tool. It will help you to clean all GVC registry entry properly.

  • LarryLarry All-Knowing Sage ✭✭✭✭

    @gsitton - agree with @Ajeesh and using Revo to uninstall.

    Oh, and for sake of your computer's hygiene, uninstall Revo after you've completed the installation of the GVC. You don't want to leave it hanging around.

  • gsittongsitton Newbie ✭

    @Ajishlal that didn't work since it couldn't find the uninstall or any program.

    This is more inlikely because I not only ran the Sonicwall VPN uninstaller, I also went through and deleted all registry items linking sonicwall vpn.

  • LarryLarry All-Knowing Sage ✭✭✭✭

    OK, list of available options:

    Did you take a back-up of the Registry before deleting those entries? If so, restore them.

    If not, do a System Restore and "go back in time" to where you hadn't uninstalled.

    In either case, you should be able to use one of the wiper utilities.

    If none of that works, manually rescan the Registry to see if there are any fragments you might have missed.

    Check Services to ensure nothing is there, either.

    Then look in C:\Program Files, C:\Program Files (x86), C:\ProgramData, and C:\Users\<username>\AppData\all folders for all remaining SW traces and delete them.

    Good luck!

  • gsittongsitton Newbie ✭

    HI @Larry

    The only system Restore was from after the day it happened. So the program wasn't there when I did the restore.

    All folders in those directories were already removed, either manually or by uninstall.

  • AjishlalAjishlal Community Legend ✭✭✭✭✭

    Hi @gsitton

    If you have the GVC version 4.9.9 (Which is telling already installed) try to do the setup again and do the repair option. Once the installation completed, use the Revo uninstaller and uninstall from registry level.

  • gsittongsitton Newbie ✭

    Hi @Ajishlal

    I was trying to do that, but I don't have that version. Been trying to find it.


  • AjishlalAjishlal Community Legend ✭✭✭✭✭

    Hi @gsitton

    its available in MySonicwall download center.

  • gsittongsitton Newbie ✭

    Thanks @Ajishlal

    I was looking for it in another spot.

    I tried this, however now I get this error

  • AjishlalAjishlal Community Legend ✭✭✭✭✭

    Hi @gsitton

    Please let me know the above solution helped you to install the GVC or not?

  • gsittongsitton Newbie ✭

    Hi @Ajishlal

    That sort of worked.

    It installed, I used Revo to uninstall it, but got the same error when I tried to install 4.10.

    So I extracted the .msi file for 4.10 and ran that and it installed and is working.



Sign In or Register to comment.