Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

Sonicwall to Azure VPN - Unable to connect to SMB share on other side of tunnel.

Hi Folks.

Looking for some assistance on issue with On-Prem to Azure VPN connection which is driving me nuts.

Basically, the tunnel is CONNECTED allowing RDP connections to the cloud server on Azure , but I'm unable to access SMB folder share and cannot ping the host on the Azure side.

This was setup before and working fine so I know it's doable, but the firewall died and had to replaced.

This is a TZ300 appliance.

Here is the guide i used to create the Tunnel, which had worked great previously.

https://www.sonicwall.com/support/knowledge-base/how-can-i-configure-a-vpn-between-a-sonicwall-firewall-and-microsoft-azure/170505320011694/

I've checked the routing etc, but just can't get this thing to work


Any suggestion would be appreciated .

Category: Entry Level Firewalls
Reply
Tagged:

Answers

  • @TedSter,

    I would suggest doing a packet capture to analyze what is actually happening with the traffic. Feel free to share a screenshot and I can let you know what it looks like.

    Thanks!

    Shipra Sahu

    Technical Support Advisor, Premier Services

  • TedSterTedSter Newbie ✭


    Hi @shiprasahu93

    Thank you for responding.

    I haven't really used the packet monitor much previously , so I'm not sure if what I've captured would be helpful to you.

    Here is a snapshot of the capture.


    Thanks





  • @TedSter,

    Feel free to use these filters so that we can get the traffic that we want to monitor.

    Under the packet monitor tab:


    - Settings tab: Uncheck everything

    - Monitor Filter tab:

    * Check “Enable Bidirectional address and port matching"

    * Ether type: IP

    * IP Type: ICMP, TCP

    * Destination IP: Mention the IP address of the Azure side that you are trying to connect with

    * Everything else clear

    - Display Filter Tab: Everything clear, all boxes check

    - Advance Monitor Filter: Everything check

    - Click OK, and Start Capture.

    Thanks!

    Shipra Sahu

    Technical Support Advisor, Premier Services

  • TedSterTedSter Newbie ✭

    Thank you again for getting back to me.

    I tired setting up the filter as you instructed , but I'm not capturing any traffic.

    Stopped and restated a few times, still no traffic.


    See the screenshots below :


    FYI .. maybe this would help with your analysis.

    I've been exploring a bit and connected via RDP the host server ( 10.0.4.) on the Azure side, and was able to ping the Sonicwall (192.167.97.1) from that side of the tunnel. I was not able to ping any other devices inside the network .


    Thanks !



  • @TedSter,

    Are you testing from the source computer with IP: 192.168.97.1 or is that the IP of the SonicWall? Could you please remove that source IP address and just use the destination field?

    Thanks!

    Shipra Sahu

    Technical Support Advisor, Premier Services

  • TedSterTedSter Newbie ✭

    @shiprasahu93

    192.168.97.1 is the Sonicwall.

    I removed the source IP and still no packets.

  • So, you are sending ping and RDP traffic but don't see anything on the SonicWall? Looks like this needs some real-time troubleshooting.

    Shipra Sahu

    Technical Support Advisor, Premier Services

  • TedSterTedSter Newbie ✭


    Thank you for trying to assist @shiprasahu93

    I am able to RDP from any workstation in the office network (192.167.97.0/24) to the Azure server (10.0.1.4/24), but I cannot ping the server. Nor can I access shared folder which was previously accessible.


    Thanks again.

  • @TedSter,

    I understand. Since we are not seeing any traffic on the firewall, I am not sure how we should proceed. I would suggest reaching our Technical Support team so that they can assist you in real-time.

    Thanks!

    Shipra Sahu

    Technical Support Advisor, Premier Services

Sign In or Register to comment.