Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

Need help getting data back from EXP file

LarryLarry Cybersecurity Overlord ✭✭✭

On a TZ350, CSR handling a case suggested exporting Settings, updating firmware from 79n to 83n, rebooting to factory default and then importing Settings.

Now I find that all of my custom Address Objects are missing.

Does anyone know of ANY mechanism that can enable me to get them back?

That's a huge amount of work - I'm pretty frantic now.


Thanks!

Category: Entry Level Firewalls
Reply

Best Answer

Answers

  • LarryLarry Cybersecurity Overlord ✭✭✭

    @preston - it turns out that the export I made before the firmware upgrade was missing the data.

    I had to go back about a month to find the last version, which did have what I needed.

    Running a comparison between the two CLI text files to find out what else was changed between 10/24 and yesterday.

  • prestonpreston Enthusiast ✭✭
    @Larry, it sounds like it would be easier to reimport the original file and just make the changes then, would save having to manually re-import the objects via the cli
  • LarryLarry Cybersecurity Overlord ✭✭✭

    @preston - that's what I did. Took the 10/24 file (79n) and imported into the 83n box. Was very surprised that importing the settings automatically rebooted the device, but was told by the CSR that it could happen.

    Turns out the backup I took yesterday 11/19 was "short" by about 200KB. No explanation as to how that could have happened.

  • prestonpreston Enthusiast ✭✭
    edited November 21
    @Larry , yes when importing the config it always restarts the appliance, when you import the config file it checks to see if there are any errors also,
    sometimes when you have weird issues happening like not been able to delete an object or users group, the first thing I do is export and reimport the config, then it will usually let you delete them after.
Sign In or Register to comment.