Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".


How to force GMS primary agent to reclaim a unit under backup agent management

We recently upgraded from GMS 8.7 to GMS 9.2. We have a 2-agent distributed installation with one also acting as the console and database server. For the purposes of this post we'll call the console agent "console" and the other agent "agent 2." We had our c. 600 units evenly distributed between the 2 agents in GMS 8.7. Shortly after we imported the units into GMS 9.2 for some reason a large number of units assigned to the "console" ended up being actively managed by "agent 2." Now "agent 2" is bogging down at summarization because of the large number of syslog files it has to process. I tried moving some of the units under active management by "agent 2" back to "console," but changing the primary and backup agents in the re-assign unit action seems to make no change. When I do it no new tasks are created and the units continue to be managed by "agent 2." I guess I shouldn't be surprised, since the units are already configured to use "console" as their primary agent. Trouble is, I can't find a way to force GMS to have "console" manage the units again. Any idea how I can make this happen?

Category: Firewall Management and Analytics

Best Answer

  • Options
    amervendamervend Newbie ✭
    Answer ✓

    I tried and discovered that the scheduler on the console system is not executing tasks. There is clearly some more fundamental problem with my install. Filing a case.


  • Options
    BrianBrian SonicWall Employee

    Hello Amervend,

    Are the agent one and two being used as standby agents for all the units? There is an option in the internal settings of the firewall units (.diag.html) Management settings> Use Standby Management SA. If you uncheck this option, the unit will no longer use the standby agent. If both agents are up, I recommend running a synch task for all units in GMS. During the synch this option in the internal settings should disable and the units will then be managed by the primary agent.

    If you are still having this issue after doing the synch tasks, open a support case for further review.

Sign In or Register to comment.