Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

Standalone Configuration of SonicWall Switch 14-24FPOE

RozRoz Newbie ✭

I have 14-24FPOE switch. Current Firmware is-1.0.0.2-10s. I'm unable to configure interfaces. I want to configure the following configuration on port 1


switchport trunk encapsulation dot1q

 switchport trunk native vlan 101

 switchport trunk allowed vlan 10,20,30,40

 switchport mode trunk

 switchport nonegotiate


I don't have a SonicWall Firewall. Can I configure Switch without a Firewall?

I also try to configure switch from CLI but it didn't accept the trunk command.

Does anyone know where am I doing a mistake? Please let me know if anyone has a solution.


Category: Switches
Reply

Best Answers

  • CORRECT ANSWER
    MasterRoshiMasterRoshi Moderator
    Accepted Answer

    @Roz ,

    Trunk or access port is decided by whether you have multiple allowed VLAN's or not. For your example, it would be the below.

    VLAN -> 802.1Q -> Create your VLAN 220

    VLAN -> 802.1Q -> Edit VLAN 220 and put the port in question as 'untagged' in the list

    Switching -> Port Settings -> Edit port and set the Native VLAN 220

    We cannot comment on ports right now but you can give each VLAN a name.

    @Mallik -- this is a good feature request (allow comments on each port).

  • CORRECT ANSWER
    RozRoz Newbie ✭
    Accepted Answer

    Thank you so much. I create all VLAN's and also add native VLAN as above.

    now, what if I have multiple allowed VLAN's?

    Foe Example: I want to configure interface 7-12

    switchport access vlan 220

    switchport mode access

    and in interface 1-5 I want to configure

    switchport access vlan 202

    switchport mode access


    while in interface 6,15-24

    switchport trunk encapsulation dot1q

    ✔️ switchport trunk native vlan 20

    ✔️ switchport trunk allowed vlan 1,10,20,30

     switchport mode trunk


    so how can I apply this configuration in switch?

  • CORRECT ANSWER
    MasterRoshiMasterRoshi Moderator
    Accepted Answer

    @Roz,

    The idea is the same as the last two examples.

    7-12

    VLAN -> 802.1Q -> Create your VLAN 220

    VLAN -> 802.1Q -> Edit VLAN 220 and put port 7-12 in question as 'untagged' in the list

    Switching -> Port Settings -> Edit port 7-12 and set the Native VLAN 220

    1-5

    VLAN -> 802.1Q -> Create your VLAN 202

    VLAN -> 802.1Q -> Edit VLAN 202 and put port 1-5 in question as 'untagged' in the list

    Switching -> Port Settings -> Edit port 1-5 and set the Native VLAN 202

    6,15-24

    VLAN -> 802.1Q -> Create your VLAN's (1,10,20,30)

    VLAN -> 802.1Q -> Edit VLAN's 1,10,30 and put ports 6,15-24 in question as a 'tagged' port

    VLAN -> 802.1Q -> Edit VLAN 20 and put the ports 6,15-24 in question as 'untagged'

    Switching -> Port Settings -> Edit ports 6,15-24 and set the Native VLAN to 20.

Answers

  • RozRoz Newbie ✭

    Thanks a lot @MasterRoshi. It works.

    How to add an Interface description and how can I configure switchport access and trunk?

    For Example: switchport access vlan 220

     switchport trunk encapsulation dot1q

     switchport mode access

    spanning-tree portfast

  • RozRoz Newbie ✭

    Thank you so much @MasterRoshi. I appreciate your help.

    How can I enable routing ? If I wanna configure as follow How can I give ip to vlan 20 and how to add ip route?

    interface Vlan20

     ip address 10.2.2.248 255.255.255.0

    ip default-gateway 10.2.2.254

    ip classless

    ip route 0.0.0.0 0.0.0.0 10.2.2.254 254

    ip route 0.0.0.0 0.0.0.0 10.79.3.1 254

    ip route 0.0.0.0 0.0.0.0 10.79.3.1 254

    ip http server

    ip http secure-server

    ip sla enable reaction-alerts

    access-list 10 permit 10.2.0.35

  • @Roz,

    Our switches only do static routing (for system traffic). We currently do not have Layer3/routing functionality like in your example.

    You can configure the L3 stuff in your firewall or router. The access list as well (although you can do access list to an extent in Security -> ACL Management -> IPv4 ACE).

Sign In or Register to comment.