Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

Set up PPPoE on TZ350 W

SonicwallUserSonicwallUser Newbie ✭
edited October 23 in Entry Level Firewalls

Hi,

I am unable to set up the PPPoE for my TZ350 W firewall. I've entered in my PPPoE username and password, but the status is still showing "WAN interface X1 Disconnected".

  • Restarted modem and firewall
  • Checked username and passwords

Modem: C3000Z through Century Link - Protocol selected is PPPoE.

Any thoughts or suggestions?

Thanks!

Category: Entry Level Firewalls
Reply

Answers

  • SaravananSaravanan Moderator
    edited October 23

    Hi @SonicwallUser,

    Thank you for visiting SonicWall Community.

    • Do you have any IP subnet in 192.168.1.x/24 configured on any of the firewall interfaces currently?
    • Could you connect a laptop to the modem and check the IP address scheme that the laptop receives from the modem? (This step is to ensure there is no overlapping subnets between modem and firewall)
    • If these steps doesn't work, please go through the firewall GUI logs to understand the reason for the failure.

    Let us know how it goes.

    Note: Moved the post to "Entry Level Firewalls" category for precise results.

    Regards

    Saravanan V

    Technical Support Advisor - Premier Services

    Professional Services

  • Hi Saravan,

    The wireless on the laptop works through the modem still and does have a 192.168... IP address. My firewall is set to a 10.0.1.0/24 network address.

    Should I change the modem's IP address scheme?

  • AjishlalAjishlal Cybersecurity Overlord ✭✭✭
    edited October 23

    Hi @SonicwallUser ,

    For configiuring the PPPOE in Firewall, You would have to configure the Modem as "Transparent Bridging" mode.

    Login to the Modem --> Go to Advanced Setup --> WAN Settings --> Select "Transparent Bridging" for the ISP Protocol.

    to get the transport mode (VLAN Setting) that works in your area contact the support (not available in all areas).https://www.centurylink.com/home/help/contact.html?team1=tech

    Select "Apply" to save your changes.

    Then Configure the PPPoE in your Firewall.

  • SaravananSaravanan Moderator

    Hi @SONICWALLUSER,

    Not necessarily. You can change the IP scheme on the modem only when the IP subnet leased by the modem overlaps with the subnet on the SonicWall appliance.

    Could you please check the logs on the SonicWall to understand the PPPoE connection failure?

    Regards

    Saravanan V

    Technical Support Advisor - Premier Services

    Professional Services

  • SonicwallUserSonicwallUser Newbie ✭
    edited October 24

    The log says "Failed to resolve name".

  • BWCBWC Cybersecurity Overlord ✭✭✭

    Hi @SonicwallUser

    if I get this right, your PPPoE connection does not come up, is this correct? Did you do any PPPoE capturing to see if your PADI packets getting any PADO in return? This is how PPPoE works and if there is no access concentrator your PPPoE client (SNWL) cannot authenticate, no IP addresses involved at this point.

    This can be easily done in the Packet Monitor, PADI will be sent from the SNWL and PADO is the answer from your ISP. No PADO - no fun!

    A common problem can be that the PPPoE packets need to be VLAN tagged somehow, maybe you should check with your ISP if this is necessary.

    --Michael@BWC

  • Halon5Halon5 Enthusiast ✭✭
    edited November 18

    Hey @SonicwallUser ,

    Is the WAN circuit tagged with any VLAN ID by the ISP ?

    In New Zealand VDSL is often tagged VLAN 10 which presents an issue that needs to be dealt with.

    The SonicWALL also has some reserved VLAN ID's that it also uses so that starting VLAN ID may need to be changed

    Kindly, S.

  • prestonpreston Enthusiast ✭✭
    edited November 18
    Hi @SonicwallUser as @Ajishlal mentioned, the modem needs to be in a full bridged mode to use PPoE on the SonicWall WAN, the fact you still have wifi enabled on it would suggest it is still in Modem/Router mode not bridged.

    To test if PPPoe is actually enabled you can test this first via any pc by going to the control panel, internet settings, add a new connection and chose PPPoe and then enter you ISP settings, then plug the ethernet from your modem, directly in to your pc if it connects and you have a public IP address the PPPoE is working correctly if not the fault is likely to be on the modem side, just make sure if a VLAN is needed, to enable and add to your network card the relevant settings.
    Once you have established that the PPPoE connection works via the PC

    if it does require a VLAN this would be present in your current modems settings if this is the case, create a sub interface on the Sonicwall Interfaces page by selecting add interface, with the correct VLAN ID select WAN Zone and set to bind it to the X1 Interface, and add your PPPoE username and password then accept the settings, you won't need any configuration on the physical Interface.
    You will more than likely need to reboot the modem before connecting to the X1 interface.

    If it Doesn't require any VLAN then configure the X1 interface as normal choosing PPPoE as the connection method
Sign In or Register to comment.