Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

Voice VLAN on switch

Enzino78Enzino78 Newbie ✭

Hi, I've used the indication in your KB (How To Configure Voice VLAN And QoS On SonicWall Switch? - https://www.sonicwall.com/support/knowledge-base/how-to-configure-voice-vlan-and-qos-on-sonicwall-switch/200609023815257/) but I not albe to have this feature working as expected (connecting a SIP phone DHCP enabled to the switch port Voice LAN enabled would allow it to be addressed as per the network configured in Voice LAN. This not happened). Is there another guide useful to double check the steps needed to have it working? Thanks, Regards.

Category: Switches
Reply
Tagged:

Answers

  • SaravananSaravanan Moderator

    Hi @ENZINO78,

    Thank you for visiting SonicWall Community.

    Sounds like your SIP phone placed to be on part of the Voice LAN is unable to get IP address from the Voice LAN subnet. Please let us know if this is right. If yes, please check the logs on the SonicWall GUI w.r.t the voice LAN. Also, performing packet capture on the SonicWall would help us.

    Regards

    Saravanan V

    Technical Support Advisor - Premier Services

    Professional Services

  • TKWITSTKWITS Newbie ✭

    @Enzino78

    While I have not used Sonicwall's switches yet, I have found that Voice VLAN implementation depends also on the phones themselves. Some phones require LLDP to be enabled on the switchports before they will negotiate to the correct VLAN. Determining if the phones require LLDP, and whether the Sonicwall switches support LLDP configuration, would be my next steps.

  • HIS_DanielHIS_Daniel Newbie ✭

    @Enzino78

    I ran into this today as well. I configured the X0 port on my TZ570 as the main LAN interface (192.168.1.x) with a sub-interface, VLAN100 (192.168.100.x). I then created the Voice VLAN network on the switch with a DHCP pool for it. I plugged a Polycom VoIP phone into port 48 of the switch after I had configured that port as a Voice VLAN port but the phone pulled a DHCP address from the 192.168.1.x pool and not the 192.168.100.x as I thought it would have.

    I found the problem to be that I needed to edit that specific port on the switch to enable Portshield to X0. Once I did that, a new option on the edit port slide out bar appeared and gave me the option to set that port to VLAN100 as an access port. Once I did that and plugged the phone back in, it pulled a proper address from the 192.168.100.x subnet. I did not see this part in the SonicWall switch getting started guide and only realized it when I zoomed in on a picture in the guide and saw that Portshield was enabled. Maybe this will help you.

Sign In or Register to comment.