Join the Conversation

To sign in, use your existing MySonicWall account. To create a free MySonicWall account click "Register".

User Login Issue when I use google chrome - firewall TZ600 - firewall TZ600

samajsamaj Newbie ✭
edited October 2020 in Entry Level Firewalls

Hello,

in my SonicWall Firewall TZ600 Google Chrome is not working; it logins and just hangs on, postlogincheck.html, it doesn't redirect to main.html, etc... Firefox and other browsers work fine. Happening on multiple computers, just with Chrome.

Below attached picture:- when I click on the login button after entering a username and password its freeze on the login page and its happen with admin users and also with other local users 

it happens only in the chrome browser

Hope to get a proper solution

Thank you!

Category: Entry Level Firewalls
Reply

Answers

  • AjishlalAjishlal All-Knowing Sage ✭✭✭✭

    Hi @samaj,

    Please upgrade your firewall firmware to SonicOS Enhanced 6.5.4.7-83n. it's worked for me.

    Chrome recently disabled RC4 support and old SonicOS releases were using RC4.


  • SaravananSaravanan Moderator
    edited October 2020

    Hi @SAMAJ,

    Please ensure the chrome browser is up-to-date. Is this problem seen after a firmware upgrade or any configuration changes to the firewall? Please disable any client AV on the computer and you could check for the issue once.

    Kind Note: Moved the post from "Web Application Firewall" to "Entry Level Firewalls" category for precise results.

    Regards

    Saravanan V

    Technical Support Advisor - Premier Services

    Professional Services

  • Hello...


    I am having the same issue. I am using the current version of Chrome (87.0.4280.67) on Mac and multiple different SonicWall models all on the 6.5.4.7-83n firmware. The issue did not start until upgrading to the 6.5.4.7-83n firmware. I can access these devices from Chrome on Windows or Safari on Mac. With Chrome on Mac the page displays the language dropdown on the logon screen (this is not present when accessing with Chrome on Windows). After logging in successfully the page hangs and the url bar shows /postlogincheck.html


    Please advise.

  • Hi @EVANMANDEL,

    I'm not seeing any similar issues that are reported to us previously. Possibly, could you please restart the firewall once and check the SonicWall access?

    If the issue persists, please approach our support team to report the issue.

    Regards

    Saravanan V

    Technical Support Advisor - Premier Services

    Professional Services

  • I have this exact issue immediately after upgrading my firmware. This only affects me on my Mac in either Chrome or Edge. This only works on Safari or Windows browsers.

    Like above, I get a language pull-down that I've never had before, followed by a blank html page for postlogincheck.html. I opened debug and captured the error below.


  • @CHEFGUITARTX - If you haven't reported this issue yet, please approach our support team to get immediate assistance on this as the issue needs real-time assistance.


    Regards

    Saravanan V

    Technical Support Advisor - Premier Services

    Professional Services

  • RB23RB23 Newbie ✭

    I have been facing this same issue for at least a month only on MAC computers when using Chrome. The only resolution is to use Firefox. On my PC's Chrome works fine. I even did a system complete reinstall just to see if it would resolve this lone issue and that did not work.

  • samajsamaj Newbie ✭

    Hello,

    thanks for reply..

    Still have this kind of problem, i have updated browsers, firmware etc.


  • prestonpreston Enthusiast ✭✭

    Hi @samaj , I don't know if this will fix the issue for you , this is what I had to do when testing on a Gen7 appliance but the same should apply for the Gen6 Appliances, this will only work though if all the users are on the same subnet.

    Under Users/Settings Web Login, enable "On redirecting unauthenticated users, redirect to an external login page" like below and put in the SonicWall interface IP with the port number used to login and then select Accept,

    then try again, this worked for me in both Firefox and Chrome.


  • jbodinejbodine Newbie ✭

    I am having the same problem on my Mac running Big Sur. Both Chrome and Brave browsers get hung up logging in on the postlogincheck.html page. I have a Mac running Catalina and Chrome and Brave work fine. I tried all of the suggestions above too.

  • BryanWBryanW Newbie ✭

    postlogincheck.html @ line 14 fails because the module browserCheck-6.2.5-1268400883(eng) is failing with a bad version check. The macOS check fails because it assumes version 10, BigSur is version 11:

    this.agent = "Mozilla/5.0 (Macintosh; Intel Mac OS X 11_0_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.88 Safari/537.36"

    if (/Windows/.test(this.os)) {

    this.osVersion = /Windows (.*)/.exec(this.os)[1];

    this.os = 'Windows';

    }

    switch (this.os) {

    case 'Mac OS X':

    this.osVersion = /Mac OS X (10[\.\_\d]+)/.exec(this.agent)[1];

    break;


    case 'Android':

    this.osVersion = /Android ([\.\_\d]+)/.exec(this.agent)[1];

    break;


    case 'iOS':

    this.osVersion = /OS (\d+)_(\d+)_?(\d+)?/.exec(this.agent);

    this.osVersion = this.osVersion[1] + '.' + this.osVersion[2] + '.' + (this.osVersion[3] | 0);

    break;

    }

    return this;

  • RB23RB23 Newbie ✭

    Yeah it appears to be more of a "Big Sur" issue. Chrome works fine on PC and older OSX. If you ever find a fix please let me know.

  • dcmoodydcmoody Newbie ✭

    Exact same issue is happening for me, already on the latest firmware for NSA3600, use Chrome on MacOS Big Sur. hangs on postlogincheck.html

  • BryanWBryanW Newbie ✭

    @Saravanan - this has been a very frustrating experience with technical support. I filed a report but I can't seem to get this outside of your tier 1 scripts.

    This code bug is evident to anyone who can read the code and understands the regex being used.

    The user agent reported under macOS BigSur is:

                "Mozilla/5.0 (Macintosh; Intel Mac OS X 11_0_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.88 Safari/537.36"

    Please note the Mac OSX 11 in the user agent string.

    The code in browserCheck-6.2.5-1268400883(eng).js *assumes* the version string contains Mac OS X 10.

    This particular regex comparison below for the OS version returns null because the browser's reported user agent does not match the expected version. The regex returns a null on BigSur, then attempts to index into null resulting in the uncaught type error.

                    switch (this.os) {

                            case 'Mac OS X':

                                    this.osVersion = /Mac OS X (10[\.\_\d]+)/.exec(this.agent)[1];

                                    break;

    The result here is that this line to do the assignment for "this.osVersion" throws an exception at line 181 of this file:

                Uncaught TypeError: Cannot read property '1' of null

    This causes the page to halt and results in a blank screen, it is not possible to login on BigSur with this bug (without using a workaround below) in the firmware.

    The issue can be worked around in the browser by changing the user agent to return the OS version expected in the code but this is not an appropriate fix nor do I want my browser reporting the incorrect version.

  • MicahMicah Administrator

    Hello @BryanW,

    I'm sorry for this inconvenience. Thank you for your detailed write up of the issue. I just recently PMd you. Can you send me your case number so we can work to escalate this?

    Kind Regards,

    🖐️ Sr. Manager, Web and Digital, SonicWall. Say "hi" by tagging me at @micah.

  • martymarty Newbie ✭

    Hey guys, any update on this? I recently got a new mac with big sur, and noticed the same thing. So far Safari is the only browser that works.

  • BjörnBjörn Newbie

    Hi,

    same for me. MacOS Big Sur with Chrome stuck after login in postlogincheck.html seeing only a blank page.

    Firefox and Safari on same MacOS BigSur working just fine, but well I'm a chrome user like approximately 70% of the users worldwide.

  • dan2021dan2021 Newbie ✭

    Same for me. MacMini running MacOS 11.1, Chrome Version 87.0.4280.141.

    Works OK with Safari.

    My pet peeve is why the default case is to fail. For that matter, why bother checking the browser version? Yes, I understand that the user experience might be poor with an old browser but let that be my decision. What if I happen to use a browser that Sonicwall has never heard of before? Having the default be to fail is a bad choice in my opinion. I'm lucky that there are other browsers that are working. I might have been left in a situation where no browsers work because they are all newer than the Sonicwall firmware. That would make it very hard for me to upgrade to a working firmware.

    I hope Sonicwall fixes this soon.

  • dan2021dan2021 Newbie ✭

    Error is in browserCheck-6.2.5-1268400883(eng).js

    switch (this.os) {

    case 'Mac OS X':

    this.osVersion = /Mac OS X (10[\.\_\d]+)/.exec(this.agent)[1];

    break;

    The UserAgent for my version of Chrome is below.

    Mozilla/5.0 (Macintosh; Intel Mac OS X 11_1_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.141 Safari/537.36

  • For those affected by the browser check on Chrome in Big Sur, you can request hotfix for GEN6-1966 from the support team.

  • We have this problem with several various firewalls we manage using newer Mac's. Any idea when this fix will be pushed to mysonicwall.com and not need a support ticket to update each device model?

  • scottregbscottregb Newbie ✭

    I have a ticket open on this exact issue. Case# 43626729  

    Need a fix please!

  • NatNat Newbie

    @MasterRoshi

    As I created a ticket to request the hotfix firmware, support asked me to provide config, tsr and tracelogs.

    This make no sense as this is a firewall coding issue, why they consist to ask me provide my firewall info. especially config & tracelogs?

    #43629081

    Hello Nat,


    We need provide below files to our backend team before downloading the Hotfix firmware for the device, I would request you to please provide the files and we will attach the Hotfix to the case.


    1-Downloading the Tech-Support Report (TSR) file:

    Go to System > Diagnostics and check all of the boxes listed.

    Then select Download Report.

    Once the download has completed, please attach the file to the case.


    2- Exporting the Settings (EXP) file:

    System>Settings> Export Settings. Once the download has completed, please attach the file to the case.


    3- Attach all three Trace logs -

    For tracelogs refer the article below.

    https://www.sonicwall.com/en-us/support/knowledge-base/170505799776273


    Regards,

    Pramod Mankar

  • PyrsArtPyrsArt Newbie ✭

    Is this hotfix from Apple or Sonicwall or Chrome? I couldn't find anything on the internet except this thread that mentions it. Thank you.

  • PyrsArtPyrsArt Newbie ✭

    I have the same exact problem. Would really like the hot fix or at least to have it fixed in the next firmware update. It seems rediculous to even be hardcoding such a check in the first place. However, Sonicwall must have its reasons. Just want it fixes so I don't have to use Safari for this one thing. I stay in Chrome all day.

  • NatNat Newbie

    @MasterRoshi @Saravanan @Micah @shiprasahu93

    Is the GEN6-1966 hotfix firmware really ready for public?

    I had created a ticket for it since Feb26, they request me to provide a lot of stuffs. EXP, TSR, tracelogs.( What are you using with my EXP & tracelogs???)

    However, I still have no updates from SonicWALL on the firmware. It's over 20 days.

  • SaravananSaravanan Moderator

    Hi @Nat,

    I verified the resource and it looks like the HF is available for certain device models. Could you please approach the support team on your respective case number and check?

    Regards

    Saravanan V

    Technical Support Advisor - Premier Services

    Professional Services

  • JürgJürg Newbie ✭

    I applied for the HF via support ticket on Feb 26.

    more or less immediately and without any further logs etc got the patch for TZ400

    still waiting for TZ600, NSA2600, NSA4600

    guess i wont see those until a new firmware is out that hopefully contains the fix.

  • MasterRoshiMasterRoshi Moderator

    Hotfixes can be requested for each model.

  • JürgJürg Newbie ✭

    and then you wait for almost one month and still no HF made available (for my TZ600, NSA2600, NSA4600)

Sign In or Register to comment.